blob: ff673e21bb5be0f1ea2d71cbfac14d70c1c69020 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A command line tool for updating and displaying info about boot loaders"
2DESCRIPTION = "grubby is a command line tool for updating and displaying information \
3about the configuration files for the grub, lilo, elilo (ia64), yaboot (powerpc) and \
4zipl (s390) boot loaders. It is primarily designed to be used from scripts which install \
5new kernels and need to find information about the current boot environment. \
6"
7HOMEPAGE = "https://github.com/rhboot/grubby"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008LICENSE = "GPL-2.0-or-later"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009
10LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
11
Andrew Geissler517393d2023-01-13 08:55:19 -060012DEPENDS = "popt util-linux rpm"
13DEPENDS:append:libc-musl = " libexecinfo argp-standalone"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014
15S = "${WORKDIR}/git"
Andrew Geissler517393d2023-01-13 08:55:19 -060016SRCREV = "c01b0d5bb182bde35b464d14996acf354a3ada2e"
17SRC_URI = "git://github.com/rhboot/grubby.git;protocol=https;;branch=main \
18 file://0001-rename-grub2-editenv-to-grub-editenv.patch \
19 file://0002-Add-another-variable-LIBS-to-provides-libraries-from.patch \
20 file://0003-include-paths.h-for-_PATH_MOUNTED.patch \
21 file://0004-rpm-sort-include-string.h-for-strverscmp.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022 file://run-ptest \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023 "
24
Patrick Williams213cb262021-08-07 19:21:33 -050025RDEPENDS:${PN} += "dracut"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026
27inherit autotools-brokensep ptest
28
Andrew Geissler517393d2023-01-13 08:55:19 -060029EXTRA_OEMAKE = "-e 'CC=${CC}' 'LDFLAGS=${LDFLAGS}' 'LIBS=${LIBS}'"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030
Andrew Geissler517393d2023-01-13 08:55:19 -060031LIBS:libc-musl = "-lexecinfo -largp"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080032LIBS ?= ""
33do_install_ptest() {
34 install -d ${D}${PTEST_PATH}
35 cp -r ${S}/test ${S}/test.sh ${D}${PTEST_PATH}
36 sed -i 's|./grubby|grubby|' ${D}${PTEST_PATH}/test.sh
37}
38
Patrick Williams213cb262021-08-07 19:21:33 -050039RDEPENDS:${PN} += "bash"
40RDEPENDS:${PN}-ptest = "util-linux-getopt bash"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080041
Andrew Geissler595f6302022-01-24 19:11:47 +000042inherit update-alternatives
Andrew Geissler615f2f12022-07-15 14:00:58 -050043ALTERNATIVE:${PN} = "installkernel"
Andrew Geissler595f6302022-01-24 19:11:47 +000044ALTERNATIVE_LINK_NAME[installkernel] = "${sbindir}/installkernel"
45
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080046COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'