blob: 6797899808fb7e754f0a01028bc03d8ef43e63a8 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Mycroft is a hackable open source voice assistant."
2DESCRIPTION = "Mycroft is the world’s first open source assistant. "
3HOMEPAGE = "https://mycroft.ai/"
4SECTION = "multimedia"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=79aa497b11564d1d419ee889e7b498f6"
8
Brad Bishop6a62e0e2019-10-21 08:11:42 -04009SRCREV = "913f29d3d550637934f9abf43a097eb2c30d76fc"
Andrew Geissler595f6302022-01-24 19:11:47 +000010SRC_URI = "git://github.com/MycroftAI/mycroft-core.git;branch=master;protocol=https \
Brad Bishopc342db32019-05-15 21:57:59 -040011 file://0001-Remove-python-venv.patch \
Brad Bishop6a62e0e2019-10-21 08:11:42 -040012 file://0002-dev_setup.sh-Remove-the-git-dependency.patch \
13 file://0003-dev_setup.sh-Remove-the-TERM-dependency.patch \
Brad Bishop2d39a062019-10-28 08:33:36 -040014 file://0004-dev_setup.sh-Ignore-missing-package-manager.patch \
15 file://0005-pip-requirements-Don-t-install-requirements-with-pip.patch \
16 file://0006-Use-python3-and-pip3-instead-of-python-and-pip.patch \
17 file://0007-mycroft.conf-Use-pocketsphinx-by-default.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040018 file://dev_opts.json \
19 file://mycroft-setup.service \
20 file://mycroft.service \
21 "
22
23S = "${WORKDIR}/git"
24
Andrew Geissler517393d2023-01-13 08:55:19 -060025inherit systemd features_check
Brad Bishopc342db32019-05-15 21:57:59 -040026
27# Mycroft installs itself on the host
28# Just copy the setup files to the rootfs
Brad Bishop6a62e0e2019-10-21 08:11:42 -040029# The mycroft-setup service will copy the files to /var/ where we run them from
Brad Bishopc342db32019-05-15 21:57:59 -040030do_install() {
31 install -d ${D}${libdir}/
32 cp -r ${B} ${D}${libdir}/mycroft
33 rm -r ${D}${libdir}/mycroft/.git
34
35 # Install the dev opts so it doesn't ask us on initial setup.
36 install -m 644 ${WORKDIR}/dev_opts.json ${D}${libdir}/mycroft/.dev_opts.json
37
38 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
39 install -d ${D}${systemd_unitdir}/system
40 install -m 644 ${WORKDIR}/mycroft-setup.service ${D}${systemd_unitdir}/system
41 sed -i -e 's,@LIBDIR@,${libdir},g' ${D}${systemd_unitdir}/system/mycroft-setup.service
42 fi
43
44 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
45 install -d ${D}${systemd_unitdir}/system
46 install -m 644 ${WORKDIR}/mycroft.service ${D}${systemd_unitdir}/system
47 sed -i -e 's,@LIBDIR@,${libdir},g' ${D}${systemd_unitdir}/system/mycroft.service
48 fi
49}
50
Patrick Williams213cb262021-08-07 19:21:33 -050051FILES:${PN} += "${libdir}/mycroft"
Brad Bishopc342db32019-05-15 21:57:59 -040052
Patrick Williams213cb262021-08-07 19:21:33 -050053RDEPENDS:${PN} = "python3"
Brad Bishopc342db32019-05-15 21:57:59 -040054
Patrick Williams213cb262021-08-07 19:21:33 -050055RDEPENDS:${PN} += "python3-requests python3-pillow \
Brad Bishopc342db32019-05-15 21:57:59 -040056 python3-tornado python3-pyyaml \
57 python3-pyalsaaudio python3-inflection \
58 python3-pyserial python3-psutil \
59 python3-pyaudio python3-fann2 \
60 python3-pocketsphinx \
Brad Bishop6a62e0e2019-10-21 08:11:42 -040061 python3-xxhash python3-pako \
62 python3-six python3-cryptography \
63 python3-requests-futures \
64 python3-xmlrunner python3-fasteners \
65 python3-python-vlc \
66 python3-padatious python3-padaos \
67 python3-petact python3-precise-runner \
68 python3-pulsectl python3-pychromecast \
69 python3-msm python3-msk \
70 python3-websocket-client \
71 python3-google-api-python-client \
Brad Bishopc342db32019-05-15 21:57:59 -040072 "
73
Brad Bishop6a62e0e2019-10-21 08:11:42 -040074# These packages need to be installed on the target
75# python3-speechrecognition python3-pyee==5.0.0 python3-six==1.10.0
76# python3-websocket-client==0.54.0 python3-gtts python3-gtts-token
77# python3-python-dateutil python3-adapt-parser python3-lazy
78
Brad Bishopc342db32019-05-15 21:57:59 -040079# Mycroft uses Alsa, PulseAudio and Flac
Patrick Williams213cb262021-08-07 19:21:33 -050080RDEPENDS:${PN} += "alsa-utils alsa-plugins alsa-tools"
81RDEPENDS:${PN} += "pulseaudio pulseaudio-misc pulseaudio-server"
82RDEPENDS:${PN} += "flac mpg123"
Brad Bishopc342db32019-05-15 21:57:59 -040083
84# Mycroft can do this itself on the target, but it's quicker to do it here
Patrick Williams213cb262021-08-07 19:21:33 -050085RDEPENDS:${PN} += "mimic"
Brad Bishopc342db32019-05-15 21:57:59 -040086
Andrew Geisslerd688a012020-09-18 13:36:00 -050087# pgrep is used by stop-mycroft.sh
Patrick Williams213cb262021-08-07 19:21:33 -050088RDEPENDS:${PN} += "procps"
Andrew Geisslerd688a012020-09-18 13:36:00 -050089
Patrick Williams0ca19cc2021-08-16 14:03:13 -050090# More tools needed by scripts
91RDEPENDS:${PN} += "bash jq libnotify"
92
Patrick Williams213cb262021-08-07 19:21:33 -050093SYSTEMD_SERVICE:${PN} = "mycroft-setup.service mycroft.service"
Andrew Geissler517393d2023-01-13 08:55:19 -060094
95REQUIRED_DISTRO_FEATURES += "pulseaudio"