blob: 5ca0b49b69ecbb44a7c51ec1490ef1691fef2fb6 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "OVMF - UEFI firmware for Qemu and KVM"
2DESCRIPTION = "OVMF is an EDK II based project to enable UEFI support for \
3Virtual Machines. OVMF contains sample UEFI firmware for QEMU and KVM"
4HOMEPAGE = "https://github.com/tianocore/tianocore.github.io/wiki/OVMF"
Andrew Geissler5199d832021-09-24 16:47:35 -05005LICENSE = "BSD-2-Clause-Patent"
6LICENSE:class-target = "${@bb.utils.contains('PACKAGECONFIG', 'secureboot', 'BSD-2-Clause-Patent & OpenSSL', 'BSD-2-Clause-Patent', d)}"
Brad Bishop08902b02019-08-20 09:16:51 -04007LIC_FILES_CHKSUM = "file://OvmfPkg/License.txt;md5=06357ddc23f46577c2aeaeaf7b776d65"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008
9# Enabling Secure Boot adds a dependency on OpenSSL and implies
10# compiling OVMF twice, so it is disabled by default. Distros
11# may change that default.
12PACKAGECONFIG ??= ""
Patrick Williams93c203f2021-10-06 16:15:23 -050013PACKAGECONFIG += "${@bb.utils.contains('MACHINE_FEATURES', 'tpm', 'tpm', '', d)}"
14PACKAGECONFIG += "${@bb.utils.contains('MACHINE_FEATURES', 'tpm2', 'tpm', '', d)}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015PACKAGECONFIG[secureboot] = ",,,"
Patrick Williams93c203f2021-10-06 16:15:23 -050016PACKAGECONFIG[tpm] = "-D TPM_ENABLE=TRUE,-D TPM_ENABLE=FALSE,,"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017
Andrew Geisslerd5838332022-05-27 11:33:10 -050018# GCC12 trips on it
19#see https://src.fedoraproject.org/rpms/edk2/blob/rawhide/f/0032-Basetools-turn-off-gcc12-warning.patch
20BUILD_CFLAGS += "-Wno-error=stringop-overflow"
21
Andrew Geisslerc182c622020-05-15 14:13:32 -050022SRC_URI = "gitsm://github.com/tianocore/edk2.git;branch=master;protocol=https \
Andrew Geissler82c905d2020-04-13 13:39:40 -050023 file://0001-ovmf-update-path-to-native-BaseTools.patch \
24 file://0002-BaseTools-makefile-adjust-to-build-in-under-bitbake.patch \
Andrew Geissler09036742021-06-25 14:25:14 -050025 file://0005-debug-prefix-map.patch \
26 file://0006-reproducible.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060027 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050028
Andrew Geissler517393d2023-01-13 08:55:19 -060029PV = "edk2-stable202211"
30SRCREV = "fff6d81270b57ee786ea18ad74f43149b9f03494"
Brad Bishop08902b02019-08-20 09:16:51 -040031UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>edk2-stable.*)"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050032
33inherit deploy
34
Brad Bishopd5ae7d92018-06-14 09:52:03 -070035PARALLEL_MAKE = ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036
37S = "${WORKDIR}/git"
38
Brad Bishop1d80a2e2019-11-15 16:35:03 -050039DEPENDS = "nasm-native acpica-native ovmf-native util-linux-native"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050040
41EDK_TOOLS_DIR="edk2_basetools"
42
43# OVMF has trouble building with the default optimization of -O2.
44BUILD_OPTIMIZATION="-pipe"
45
46# OVMF supports IA only, although it could conceivably support ARM someday.
Patrick Williams213cb262021-08-07 19:21:33 -050047COMPATIBLE_HOST:class-target='(i.86|x86_64).*'
Brad Bishop6e60e8b2018-02-01 10:27:11 -050048
49# Additional build flags for OVMF with Secure Boot.
50# Fedora also uses "-D SMM_REQUIRE -D EXCLUDE_SHELL_FROM_FD".
51OVMF_SECURE_BOOT_EXTRA_FLAGS ??= ""
52OVMF_SECURE_BOOT_FLAGS = "-DSECURE_BOOT_ENABLE=TRUE ${OVMF_SECURE_BOOT_EXTRA_FLAGS}"
53
Brad Bishop08902b02019-08-20 09:16:51 -040054export PYTHON_COMMAND = "${HOSTTOOLS_DIR}/python3"
55
Brad Bishop6e60e8b2018-02-01 10:27:11 -050056do_patch[postfuncs] += "fix_basetools_location"
57fix_basetools_location () {
58}
Patrick Williams213cb262021-08-07 19:21:33 -050059fix_basetools_location:class-target() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050060 # Replaces the fake path inserted by 0002-ovmf-update-path-to-native-BaseTools.patch.
61 # Necessary for finding the actual BaseTools from ovmf-native.
62 sed -i -e 's#BBAKE_EDK_TOOLS_PATH#${STAGING_BINDIR_NATIVE}/${EDK_TOOLS_DIR}#' ${S}/OvmfPkg/build.sh
63}
64
65do_patch[postfuncs] += "fix_iasl"
66fix_iasl() {
67}
Patrick Williams213cb262021-08-07 19:21:33 -050068fix_iasl:class-native() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050069 # iasl is not installed under /usr/bin when building with OE.
70 sed -i -e 's#/usr/bin/iasl#${STAGING_BINDIR_NATIVE}/iasl#' ${S}/BaseTools/Conf/tools_def.template
71}
72
73# Inject CC and friends into the build. LINKER already is in GNUmakefile.
74# Must be idempotent and thus remove old assignments that were inserted
75# earlier.
76do_patch[postfuncs] += "fix_toolchain"
77fix_toolchain() {
78 sed -i \
79 -e '/^\(CC\|CXX\|AS\|AR\|LD\|LINKER\) =/d' \
80 -e '/^APPLICATION/a CC = ${CC}\nCXX = ${CXX}\nAS = ${AS}\nAR = ${AR}\nLD = ${LD}\nLINKER = $(CC)' \
81 ${S}/BaseTools/Source/C/Makefiles/app.makefile
82 sed -i \
83 -e '/^\(CC\|CXX\|AS\|AR\|LD\)/d' \
84 -e '/^VFR_CPPFLAGS/a CC = ${CC}\nCXX = ${CXX}\nAS = ${AS}\nAR = ${AR}\nLD = ${LD}' \
85 ${S}/BaseTools/Source/C/VfrCompile/GNUmakefile
86}
Patrick Williams213cb262021-08-07 19:21:33 -050087fix_toolchain:append:class-native() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050088 # This tools_def.template is going to be used by the target ovmf and
89 # defines which compilers to use. For the GCC toolchain definitions,
90 # that will be ${HOST_PREFIX}gcc. However, "make" doesn't need that
91 # prefix.
92 #
93 # Injecting ENV(HOST_PREFIX) matches exporting that value as env
Patrick Williams213cb262021-08-07 19:21:33 -050094 # variable in do_compile:class-target.
Brad Bishop6e60e8b2018-02-01 10:27:11 -050095 sed -i \
96 -e 's#\(ENV\|DEF\)(GCC.*_PREFIX)#ENV(HOST_PREFIX)#' \
97 -e 's#ENV(HOST_PREFIX)make#make#' \
98 ${S}/BaseTools/Conf/tools_def.template
99 sed -i \
100 -e '/^\(LFLAGS\|CFLAGS\) +=/d' \
101 -e '/^LINKER/a LFLAGS += ${BUILD_LDFLAGS}\nCFLAGS += ${BUILD_CFLAGS}' \
102 ${S}/BaseTools/Source/C/Makefiles/app.makefile \
103 ${S}/BaseTools/Source/C/VfrCompile/GNUmakefile
104 # Linking with gold fails:
105 # internal error in do_layout, at ../../gold/object.cc:1821
106 # make: *** [.../OUTPUT/Facs.acpi] Error 1
107 # We intentionally hard-code the use of ld.bfd regardless of DISTRO_FEATURES
108 # to make ovmf-native reusable across distros.
109 sed -i \
110 -e 's#^\(DEFINE GCC.*DLINK.*FLAGS *=\)#\1 -fuse-ld=bfd#' \
William A. Kennington IIIac69b482021-06-02 12:28:27 -0700111 -e 's#-flto#-fno-lto#g' \
112 -e 's#-DUSING_LTO##g' \
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500113 ${S}/BaseTools/Conf/tools_def.template
114}
115
William A. Kennington IIIac69b482021-06-02 12:28:27 -0700116# We disable lto above since the results are not reproducible and make it hard to compare
117# binary build aretfacts to debug reproducibility problems.
118# Surprisingly, if you disable lto, you see compiler warnings which are fatal. We therefore
119# have to hack warnings overrides into GCC_PREFIX_MAP to allow it to build.
120
121# We want to pass ${DEBUG_PREFIX_MAP} to gcc commands and also pass in
122# --debug-prefix-map to nasm (we carry a patch to nasm for this). The
123# tools definitions are built by ovmf-native so we need to pass this in
124# at target build time when we know the right values.
125export NASM_PREFIX_MAP = "--debug-prefix-map=${WORKDIR}=/usr/src/debug/ovmf/${EXTENDPE}${PV}-${PR}"
126export GCC_PREFIX_MAP = "${DEBUG_PREFIX_MAP} -Wno-stringop-overflow -Wno-maybe-uninitialized"
127
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500128GCC_VER="$(${CC} -v 2>&1 | tail -n1 | awk '{print $3}')"
129
130fixup_target_tools() {
131 case ${1} in
132 4.4.*)
133 FIXED_GCCVER=GCC44
134 ;;
135 4.5.*)
136 FIXED_GCCVER=GCC45
137 ;;
138 4.6.*)
139 FIXED_GCCVER=GCC46
140 ;;
141 4.7.*)
142 FIXED_GCCVER=GCC47
143 ;;
144 4.8.*)
145 FIXED_GCCVER=GCC48
146 ;;
147 4.9.*)
148 FIXED_GCCVER=GCC49
149 ;;
150 *)
151 FIXED_GCCVER=GCC5
152 ;;
153 esac
154 echo ${FIXED_GCCVER}
155}
156
Patrick Williams213cb262021-08-07 19:21:33 -0500157do_compile:class-native() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500158 oe_runmake -C ${S}/BaseTools
159}
160
Patrick Williams213cb262021-08-07 19:21:33 -0500161do_compile:class-target() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500162 export LFLAGS="${LDFLAGS}"
Brad Bishop316dfdd2018-06-25 12:45:53 -0400163 PARALLEL_JOBS="${@oe.utils.parallel_make_argument(d, '-n %d')}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500164 OVMF_ARCH="X64"
165 if [ "${TARGET_ARCH}" != "x86_64" ] ; then
166 OVMF_ARCH="IA32"
167 fi
168
169 # The build for the target uses BaseTools/Conf/tools_def.template
170 # from ovmf-native to find the compiler, which depends on
171 # exporting HOST_PREFIX.
172 export HOST_PREFIX="${HOST_PREFIX}"
173
174 # BaseTools/Conf gets copied to Conf, but only if that does not
175 # exist yet. To ensure that an updated template gets used during
176 # incremental builds, we need to remove the copy before we start.
177 rm -f `ls ${S}/Conf/*.txt | grep -v ReadMe.txt`
178
179 # ${WORKDIR}/ovmf is a well-known location where do_install and
180 # do_deploy will be able to find the files.
181 rm -rf ${WORKDIR}/ovmf
182 mkdir ${WORKDIR}/ovmf
183 OVMF_DIR_SUFFIX="X64"
184 if [ "${TARGET_ARCH}" != "x86_64" ] ; then
185 OVMF_DIR_SUFFIX="Ia32" # Note the different capitalization
186 fi
187 FIXED_GCCVER=$(fixup_target_tools ${GCC_VER})
188 bbnote FIXED_GCCVER is ${FIXED_GCCVER}
189 build_dir="${S}/Build/Ovmf$OVMF_DIR_SUFFIX/RELEASE_${FIXED_GCCVER}"
190
191 bbnote "Building without Secure Boot."
192 rm -rf ${S}/Build/Ovmf$OVMF_DIR_SUFFIX
Patrick Williams93c203f2021-10-06 16:15:23 -0500193 ${S}/OvmfPkg/build.sh $PARALLEL_JOBS -a $OVMF_ARCH -b RELEASE -t ${FIXED_GCCVER} ${PACKAGECONFIG_CONFARGS}
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500194 ln ${build_dir}/FV/OVMF.fd ${WORKDIR}/ovmf/ovmf.fd
195 ln ${build_dir}/FV/OVMF_CODE.fd ${WORKDIR}/ovmf/ovmf.code.fd
196 ln ${build_dir}/FV/OVMF_VARS.fd ${WORKDIR}/ovmf/ovmf.vars.fd
197 ln ${build_dir}/${OVMF_ARCH}/Shell.efi ${WORKDIR}/ovmf/
198
199 if ${@bb.utils.contains('PACKAGECONFIG', 'secureboot', 'true', 'false', d)}; then
Brad Bishop08902b02019-08-20 09:16:51 -0400200 # Repeat build with the Secure Boot flags.
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500201 bbnote "Building with Secure Boot."
202 rm -rf ${S}/Build/Ovmf$OVMF_DIR_SUFFIX
Patrick Williams93c203f2021-10-06 16:15:23 -0500203 ${S}/OvmfPkg/build.sh $PARALLEL_JOBS -a $OVMF_ARCH -b RELEASE -t ${FIXED_GCCVER} ${PACKAGECONFIG_CONFARGS} ${OVMF_SECURE_BOOT_FLAGS}
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500204 ln ${build_dir}/FV/OVMF.fd ${WORKDIR}/ovmf/ovmf.secboot.fd
205 ln ${build_dir}/FV/OVMF_CODE.fd ${WORKDIR}/ovmf/ovmf.secboot.code.fd
206 ln ${build_dir}/${OVMF_ARCH}/EnrollDefaultKeys.efi ${WORKDIR}/ovmf/
207 fi
208}
209
Patrick Williams213cb262021-08-07 19:21:33 -0500210do_install:class-native() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500211 install -d ${D}/${bindir}/edk2_basetools
212 cp -r ${S}/BaseTools ${D}/${bindir}/${EDK_TOOLS_DIR}
213}
214
Patrick Williams213cb262021-08-07 19:21:33 -0500215do_install:class-target() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500216 # Content for UEFI shell iso. We install the EFI shell as
217 # bootx64/ia32.efi because then it can be started even when the
218 # firmware itself does not contain it.
219 install -d ${D}/efi/boot
220 install ${WORKDIR}/ovmf/Shell.efi ${D}/efi/boot/boot${@ "ia32" if "${TARGET_ARCH}" != "x86_64" else "x64"}.efi
221 if ${@bb.utils.contains('PACKAGECONFIG', 'secureboot', 'true', 'false', d)}; then
222 install ${WORKDIR}/ovmf/EnrollDefaultKeys.efi ${D}
223 fi
224}
225
226# This always gets packaged because ovmf-shell-image depends on it.
227# This allows testing that recipe in all configurations because it
228# can always be part of a world build.
229#
230# However, EnrollDefaultKeys.efi is only included when Secure Boot is enabled.
231PACKAGES =+ "ovmf-shell-efi"
Patrick Williams213cb262021-08-07 19:21:33 -0500232FILES:ovmf-shell-efi = " \
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500233 EnrollDefaultKeys.efi \
234 efi/ \
235"
236
Brad Bishop19323692019-04-05 15:28:33 -0400237DEPLOYDEP = ""
Patrick Williams213cb262021-08-07 19:21:33 -0500238DEPLOYDEP:class-target = "qemu-system-native:do_populate_sysroot"
239DEPLOYDEP:class-target += " ${@bb.utils.contains('PACKAGECONFIG', 'secureboot', 'openssl-native:do_populate_sysroot', '', d)}"
Brad Bishop19323692019-04-05 15:28:33 -0400240do_deploy[depends] += "${DEPLOYDEP}"
241
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500242do_deploy() {
243}
Patrick Williams213cb262021-08-07 19:21:33 -0500244do_deploy:class-target() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500245 # For use with "runqemu ovmf".
246 for i in \
247 ovmf \
248 ovmf.code \
249 ovmf.vars \
250 ${@bb.utils.contains('PACKAGECONFIG', 'secureboot', 'ovmf.secboot ovmf.secboot.code', '', d)} \
251 ; do
252 qemu-img convert -f raw -O qcow2 ${WORKDIR}/ovmf/$i.fd ${DEPLOYDIR}/$i.qcow2
253 done
Brad Bishop08902b02019-08-20 09:16:51 -0400254
255 if ${@bb.utils.contains('PACKAGECONFIG', 'secureboot', 'true', 'false', d)}; then
256 # Create a test Platform Key and first Key Exchange Key to use with EnrollDefaultKeys
257 openssl req -new -x509 -newkey rsa:2048 -keyout ${DEPLOYDIR}/OvmfPkKek1.key \
258 -out ${DEPLOYDIR}/OvmfPkKek1.crt -nodes -days 20 -subj "/CN=OVMFSecBootTest"
259 openssl x509 -in ${DEPLOYDIR}/OvmfPkKek1.crt -out ${DEPLOYDIR}/OvmfPkKek1.pem -outform PEM
260 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500261}
262addtask do_deploy after do_compile before do_build
263
264BBCLASSEXTEND = "native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500265TOOLCHAIN = "gcc"