blob: b2c10e09fb0b6f7466f005e64ab762077112d340 [file] [log] [blame]
Andrew Geissler90fd73c2021-03-05 15:25:55 -06001SUMMARY = "Demo application to showcase 3D graphics using kms and gbm"
2DESCRIPTION = "kmscube is a little demonstration program for how to drive bare metal graphics \
3without a compositor like X11, wayland or similar, using DRM/KMS (kernel mode \
4setting), GBM (graphics buffer manager) and EGL for rendering content using \
5OpenGL or OpenGL ES."
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006HOMEPAGE = "https://cgit.freedesktop.org/mesa/kmscube/"
7LICENSE = "MIT"
8SECTION = "graphics"
Andrew Geissler595f6302022-01-24 19:11:47 +00009DEPENDS = "virtual/libgles3 virtual/libgles2 virtual/egl libdrm"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010
11LIC_FILES_CHKSUM = "file://kmscube.c;beginline=1;endline=23;md5=8b309d4ee67b7315ff7381270dd631fb"
12
Andrew Geissler517393d2023-01-13 08:55:19 -060013SRCREV = "345111481d654b38a72b5c3629151dc74f7a82bc"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050014SRC_URI = "git://gitlab.freedesktop.org/mesa/kmscube;branch=master;protocol=https"
Brad Bishop316dfdd2018-06-25 12:45:53 -040015UPSTREAM_CHECK_COMMITS = "1"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016
17S = "${WORKDIR}/git"
18
Brad Bishop6dbb3162019-11-25 09:41:34 -050019inherit meson pkgconfig features_check
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020
21REQUIRED_DISTRO_FEATURES = "opengl"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000022DEPENDS = "virtual/libgbm"
Brad Bishop19323692019-04-05 15:28:33 -040023
24PACKAGECONFIG ??= ""
25PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0 gstreamer1.0-plugins-base"
Andrew Geissler9aee5002022-03-30 16:27:02 +000026
27CFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '-DEGL_NO_X11=1', d)}"
28