blob: d444f9ab0cae9a76d34f54b94ae92c3dd31a1493 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4HOMEPAGE = "https://lttng.org/"
5LICENSE = "LGPL-2.1-only & GPL-2.0-only & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4"
7
8inherit module
9
10include lttng-platforms.inc
11
Patrick Williams03907ee2022-05-01 06:28:52 -050012SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
Patrick Williams03907ee2022-05-01 06:28:52 -050013 file://0009-Rename-genhd-wrapper-to-blkdev.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060014 file://0001-fix-mm-slab_common-drop-kmem_alloc-avoid-dereferenci.patch \
Andrew Geissler615f2f12022-07-15 14:00:58 -050015 "
Patrick Williams03907ee2022-05-01 06:28:52 -050016
Andrew Geissler9aee5002022-03-30 16:27:02 +000017# Use :append here so that the patch is applied also when using devupstream
18SRC_URI:append = " file://0001-src-Kbuild-change-missing-CONFIG_TRACEPOINTS-to-warn.patch"
19
Patrick Williams2390b1b2022-11-03 13:47:49 -050020SRC_URI[sha256sum] = "5a99679df7903160cbde3918fee5af90ffafc90fc96ccdefaa57cf230492b234"
Andrew Geissler9aee5002022-03-30 16:27:02 +000021
22export INSTALL_MOD_DIR="kernel/lttng-modules"
23
24EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
25
26MODULES_MODULE_SYMVERS_LOCATION = "src"
27
28do_install:append() {
29 # Delete empty directories to avoid QA failures if no modules were built
30 if [ -d ${D}/${nonarch_base_libdir} ]; then
31 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
32 fi
33}
34
35python do_package:prepend() {
36 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
37 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
38}
39
40BBCLASSEXTEND = "devupstream:target"
41SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13"
42SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630"
43SRCREV_FORMAT ?= "lttng_git"