blob: a6c229f5cf0f95e36ab82535a854d3891c6a8b98 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "PNG image format decoding library"
2DESCRIPTION = "An open source project to develop and maintain the reference \
3library for use in applications that read, create, and manipulate PNG \
4(Portable Network Graphics) raster image files. "
5HOMEPAGE = "http://www.libpng.org/"
6SECTION = "libs"
7LICENSE = "Libpng"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=5c900cc124ba35a274073b5de7639b13"
9DEPENDS = "zlib"
10
11LIBV = "16"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/${BP}.tar.xz"
14SRC_URI[sha256sum] = "1f4696ce70b4ee5f85f1e1623dc1229b210029fa4b7aee573df3e2ba7b036937"
15
16MIRRORS += "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/ ${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/older-releases/"
17
18UPSTREAM_CHECK_URI = "http://libpng.org/pub/png/libpng.html"
19
20BINCONFIG = "${bindir}/libpng-config ${bindir}/libpng16-config"
21
22inherit autotools binconfig-disabled pkgconfig
23
24# Work around missing symbols
25ARMNEON = "${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off", d)}"
26ARMNEON:aarch64 = "--enable-hardware-optimizations=on"
27EXTRA_OECONF += "${ARMNEON}"
28
29PACKAGES =+ "${PN}-tools"
30
31FILES:${PN}-tools = "${bindir}/png-fix-itxt ${bindir}/pngfix ${bindir}/pngcp"
32
33BBCLASSEXTEND = "native nativesdk"
34
35# CVE-2019-17371 is actually a memory leak in gif2png 2.x
36CVE_CHECK_IGNORE += "CVE-2019-17371"