Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU Aspell spell-checker" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | |
| 3 | DESCRIPTION = "Spell checker designed to eventually replace Ispell. \ |
| 4 | It can either be used as a library or as an independent spell checker. \ |
| 5 | Its main feature is that it does a superior job of suggesting possible \ |
| 6 | replacements for a misspelled word than just about any other spell \ |
| 7 | checker out there for the English language." |
| 8 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 9 | SECTION = "console/utils" |
| 10 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 11 | HOMEPAGE = "http://aspell.net/" |
| 12 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 13 | LICENSE = "LGPL-2.0-only | LGPL-2.1-only" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 15 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 16 | SRC_URI = "${GNU_MIRROR}/aspell/aspell-${PV}.tar.gz \ |
| 17 | file://CVE-2019-25051.patch \ |
| 18 | " |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 19 | SRC_URI[md5sum] = "012fa9209203ae4e5a61c2a668fd10e3" |
| 20 | SRC_URI[sha256sum] = "f9b77e515334a751b2e60daab5db23499e26c9209f5e7b7443b05235ad0226f2" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 21 | |
| 22 | PACKAGECONFIG ??= "" |
| 23 | PACKAGECONFIG[curses] = "--enable-curses,--disable-curses,ncurses" |
| 24 | |
| 25 | PACKAGES += "libaspell libpspell aspell-utils" |
| 26 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | RDEPENDS:${PN}-utils += "perl" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 28 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | FILES:libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*" |
| 30 | FILES:aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*" |
| 31 | FILES:${PN} = "${bindir}/aspell" |
| 32 | FILES:libpspell = "${libdir}/libpspell.so.*" |
| 33 | FILES:${PN}-dev += "${bindir}/pspell-config" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 34 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 35 | ARM_INSTRUCTION_SET:armv4 = "arm" |
| 36 | ARM_INSTRUCTION_SET:armv5 = "arm" |
| 37 | ARM_INSTRUCTION_SET:armv6 = "arm" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 38 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 39 | inherit autotools-brokensep gettext texinfo binconfig-disabled |
| 40 | |
| 41 | BINCONFIG = "${bindir}/pspell-config" |