blob: 505c21917b2175da2a6f000a2f7e50243cfc11ee [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "interface to seccomp filtering mechanism"
Andrew Geissler517393d2023-01-13 08:55:19 -06002DESCRIPTION = "The libseccomp library provides an easy to use, platform independent, interface to the Linux Kernel's syscall filtering mechanism: seccomp."
Andrew Geissler595f6302022-01-24 19:11:47 +00003HOMEPAGE = "https://github.com/seccomp/libseccomp"
4SECTION = "security"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "LGPL-2.1-only"
Andrew Geissler78b72792022-06-14 06:47:25 -05006LIC_FILES_CHKSUM = "file://LICENSE;md5=7c13b3376cea0ce68d2d2da0a1b3a72c"
Andrew Geissler595f6302022-01-24 19:11:47 +00007
8DEPENDS += "gperf-native"
9
Andrew Geisslerd5838332022-05-27 11:33:10 -050010SRCREV = "f33f95014b36f97b42f0c2290e96d5c31647ed10"
Andrew Geissler595f6302022-01-24 19:11:47 +000011
12SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.5;protocol=https \
13 file://run-ptest \
14 "
15
16S = "${WORKDIR}/git"
17
18inherit autotools-brokensep pkgconfig ptest features_check
19
20REQUIRED_DISTRO_FEATURES = "seccomp"
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[python] = "--enable-python, --disable-python, python3"
24
25DISABLE_STATIC = ""
26
27do_compile_ptest() {
28 oe_runmake -C tests check-build
29}
30
31do_install_ptest() {
32 install -d ${D}${PTEST_PATH}/tests
33 install -d ${D}${PTEST_PATH}/tools
34 for file in $(find tests/* -executable -type f); do
35 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
36 done
37 for file in $(find tests/*.tests -type f); do
38 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
39 done
Andrew Geissler78b72792022-06-14 06:47:25 -050040 for file in $(find tests/*.pfc -type f); do
41 install -m 644 ${S}/${file} ${D}/${PTEST_PATH}/tests
42 done
43 install -m 644 ${S}/tests/valgrind_test.supp ${D}/${PTEST_PATH}/tests
Andrew Geissler595f6302022-01-24 19:11:47 +000044 for file in $(find tools/* -executable -type f); do
45 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
46 done
47 # Overwrite libtool wrappers with real executables
48 for file in $(find tools/.libs/* -executable -type f); do
49 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
50 done
51}
52
53FILES:${PN} = "${bindir} ${libdir}/${BPN}.so*"
54FILES:${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
55
56RDEPENDS:${PN}-ptest = "coreutils bash"
57
Andrew Geisslerd5838332022-05-27 11:33:10 -050058PV = "2.5.4"