blob: 0f71258bc363a640feaddb9e75c762244952773f [file] [log] [blame]
Andrew Geissler6ce62a22020-11-30 19:58:47 -06001SUMMARY = "Development package for building Applications that use numa"
2HOMEPAGE = "http://oss.sgi.com/projects/libnuma/"
3DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \
4to run other programs with a specific NUMA policy and a libnuma to do \
5allocations with NUMA policy in applications."
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-2.0-only & LGPL-2.1-only"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06007SECTION = "apps"
8
9inherit autotools-brokensep ptest
10
Andrew Geissler87f5cff2022-09-30 13:13:31 -050011LIC_FILES_CHKSUM = "file://README.md;beginline=19;endline=32;md5=9f34c3af4ed6f3f5df0da5f3c0835a43"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060012
Patrick Williams2390b1b2022-11-03 13:47:49 -050013SRCREV = "10285f1a1bad49306839b2c463936460b604e3ea"
14PV = "2.0.16"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060015
Andrew Geissler595f6302022-01-24 19:11:47 +000016SRC_URI = "git://github.com/numactl/numactl;branch=master;protocol=https \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060017 file://Fix-the-test-output-format.patch \
18 file://Makefile \
19 file://run-ptest \
20 file://0001-define-run-test-target.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060021 file://0001-configure-Check-for-largefile-support.patch \
22 file://0002-shm.c-Replace-stat64-fstat64-ftruncate64mmap64-with-.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060023 "
24
25S = "${WORKDIR}/git"
26
Patrick Williams213cb262021-08-07 19:21:33 -050027LDFLAGS:append:riscv64 = " -latomic"
28LDFLAGS:append:riscv32 = " -latomic"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060029
30do_install() {
31 oe_runmake DESTDIR=${D} prefix=${D}/usr install
32 #remove the empty man2 directory
33 rm -r ${D}${mandir}/man2
34}
35
36do_compile_ptest() {
37 oe_runmake test
38}
39
40do_install_ptest() {
41 #install tests binaries
42 local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \
43 mynode nodemap node-parse pagesize prefered randmap realloc_test \
44 tbitmap tshared"
45
46 [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
47 for i in $test_binaries; do
48 install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test
49 done
50
51 local test_scripts="checktopology checkaffinity printcpu regress regress2 \
52 shmtest runltp bind_range"
53 for i in $test_scripts; do
54 install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
55 done
56
57 install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
58 install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
59}
60
Patrick Williams213cb262021-08-07 19:21:33 -050061RDEPENDS:${PN}-ptest = "bash"