blob: 30e83457c945f4518f1233a5dee7cc7cfa3e42fa [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Bash Automated Testing System"
2DESCRIPTION = "Bats is a TAP-compliant testing framework for Bash. It \
3provides a simple way to verify that the UNIX programs you write behave as expected."
4AUTHOR = "Sam Stephenson & bats-core organization"
5HOMEPAGE = "https://github.com/bats-core/bats-core"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b"
8
9SRC_URI = "git://github.com/bats-core/bats-core.git \
Andrew Geissler69721092021-07-23 12:57:00 -040010 file://0001-install.sh-consider-multilib.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040011 "
Patrick Williams213cb262021-08-07 19:21:33 -050012# v1.4.1
13SRCREV = "54e965fa9d269c2b3ff9036d81f32bac3df0edea"
Brad Bishop26bdd442019-08-16 17:08:17 -040014
15S = "${WORKDIR}/git"
16
Andrew Geissler5199d832021-09-24 16:47:35 -050017do_configure:prepend() {
18 sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats
19 sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats-exec-file
20 sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats-exec-test
21}
22
Brad Bishop26bdd442019-08-16 17:08:17 -040023do_install() {
24 # Just a bunch of bash scripts to install
Andrew Geissler69721092021-07-23 12:57:00 -040025 ${S}/install.sh ${D}${prefix} ${baselib}
Brad Bishop26bdd442019-08-16 17:08:17 -040026}
27
Patrick Williams213cb262021-08-07 19:21:33 -050028RDEPENDS:${PN} = "bash"
29FILES:${PN} += "${libdir}/bats-core/*"
Andrew Geisslere34f8962021-04-15 15:53:51 -050030
31PACKAGECONFIG ??= "pretty"
32PACKAGECONFIG[pretty] = ",,,ncurses"