Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Universal Addresses to RPC Program Number Mapper" |
| 2 | DESCRIPTION = "The rpcbind utility is a server that converts RPC \ |
| 3 | program numbers into universal addresses." |
| 4 | SECTION = "console/network" |
| 5 | HOMEPAGE = "http://sourceforge.net/projects/rpcbind/" |
| 6 | BUGTRACKER = "http://sourceforge.net/tracker/?group_id=201237&atid=976751" |
| 7 | DEPENDS = "libtirpc quota" |
| 8 | |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 9 | LICENSE = "BSD-3-Clause" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=b46486e4c4a416602693a711bb5bfa39 \ |
| 11 | file://src/rpcinfo.c;beginline=1;endline=27;md5=f8a8cd2cb25ac5aa16767364fb0e3c24" |
| 12 | |
| 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/rpcbind/rpcbind-${PV}.tar.bz2 \ |
| 14 | file://init.d \ |
| 15 | file://rpcbind.conf \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 16 | file://rpcbind_add_option_to_fix_port_number.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | file://0001-systemd-use-EnvironmentFile.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | " |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 19 | SRC_URI[sha256sum] = "5613746489cae5ae23a443bb85c05a11741a5f12c8f55d2bb5e83b9defeee8de" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 20 | |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 21 | inherit autotools update-rc.d systemd pkgconfig update-alternatives |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | |
| 23 | PACKAGECONFIG ??= "tcp-wrappers" |
| 24 | PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers" |
| 25 | |
| 26 | INITSCRIPT_NAME = "rpcbind" |
| 27 | INITSCRIPT_PARAMS = "start 12 2 3 4 5 . stop 60 0 1 6 ." |
| 28 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | SYSTEMD_SERVICE:${PN} = "rpcbind.service rpcbind.socket" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 30 | |
| 31 | inherit useradd |
| 32 | |
| 33 | USERADD_PACKAGES = "${PN}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | USERADD_PARAM:${PN} = "--system --no-create-home --home-dir / \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 35 | --shell /bin/false --user-group rpc" |
| 36 | |
| 37 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame^] | 38 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}/, \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 39 | --without-systemdsystemunitdir, \ |
| 40 | systemd \ |
| 41 | " |
| 42 | |
| 43 | EXTRA_OECONF += " --enable-warmstarts --with-rpcuser=rpc" |
| 44 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 45 | do_install:append () { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 46 | install -d ${D}${sysconfdir}/init.d |
| 47 | sed -e 's,/etc/,${sysconfdir}/,g' \ |
| 48 | -e 's,/sbin/,${sbindir}/,g' \ |
| 49 | ${WORKDIR}/init.d > ${D}${sysconfdir}/init.d/rpcbind |
| 50 | chmod 0755 ${D}${sysconfdir}/init.d/rpcbind |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 51 | } |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 52 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 53 | ALTERNATIVE:${PN} = "rpcinfo" |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 54 | ALTERNATIVE_LINK_NAME[rpcinfo] = "${bindir}/rpcinfo" |