Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Tools for zmodem/xmodem/ymodem file transfer" |
| 2 | DESCRIPTION = "Lrzsz is a cosmetically modified zmodem/ymodem/xmodem package built from \ |
| 3 | the public-domain version of Chuck Forsberg's rzsz package. \ |
| 4 | These programs use error correcting protocols ({z,x,y}modem) to send (sz, sx, sb) and \ |
| 5 | receive (rz, rx, rb) files over a dial-in serial port from a variety of programs \ |
| 6 | running under various operating systems. " |
| 7 | HOMEPAGE = "http://www.ohse.de/uwe/software/lrzsz.html" |
| 8 | LICENSE = "GPLv2+" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ |
| 10 | file://src/lrz.c;beginline=1;endline=10;md5=5276956373ff7d8758837f6399a1045f" |
| 11 | SECTION = "console/network" |
| 12 | DEPENDS = "" |
| 13 | PR = "r6" |
| 14 | |
| 15 | SRC_URI = "http://www.ohse.de/uwe/releases/lrzsz-${PV}.tar.gz \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | file://autotools-update.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 17 | file://autotools.patch \ |
| 18 | file://makefile.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 19 | file://lrzsz-check-locale.h.patch \ |
Brad Bishop | bba38f3 | 2018-08-23 16:11:46 +0800 | [diff] [blame] | 20 | file://cve-2018-10195.patch \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 21 | file://include.patch \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 22 | file://0001-Fix-cross-compilation-using-autoconf-detected-AR.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 23 | " |
| 24 | |
| 25 | SRC_URI[md5sum] = "b5ce6a74abc9b9eb2af94dffdfd372a4" |
| 26 | SRC_URI[sha256sum] = "c28b36b14bddb014d9e9c97c52459852f97bd405f89113f30bee45ed92728ff1" |
| 27 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 28 | UPSTREAM_CHECK_URI = "http://ohse.de/uwe/software/lrzsz.html" |
| 29 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 30 | inherit autotools gettext |
| 31 | |
| 32 | do_install() { |
| 33 | install -d ${D}${bindir}/ |
| 34 | install -m 0755 src/lrz src/lsz ${D}${bindir}/ |
| 35 | } |
| 36 | |
| 37 | inherit update-alternatives |
| 38 | |
| 39 | ALTERNATIVE_PRIORITY = "100" |
| 40 | |
| 41 | ALTERNATIVE_${PN} = "rz rx rb sz sx sb" |
| 42 | |
| 43 | ALTERNATIVE_TARGET[rz] = "${bindir}/lrz" |
| 44 | ALTERNATIVE_TARGET[rx] = "${bindir}/lrz" |
| 45 | ALTERNATIVE_TARGET[rb] = "${bindir}/lrz" |
| 46 | |
| 47 | ALTERNATIVE_TARGET[sz] = "${bindir}/lsz" |
| 48 | ALTERNATIVE_TARGET[sx] = "${bindir}/lsz" |
| 49 | ALTERNATIVE_TARGET[sb] = "${bindir}/lsz" |