blob: b999f13530e31cfff0b277aadf60d18d565d8539 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Zlib Compression Library"
2DESCRIPTION = "Zlib is a general-purpose, patent-free, lossless data compression \
3library which is used by many different programs."
4HOMEPAGE = "http://zlib.net/"
5SECTION = "libs"
6LICENSE = "Zlib"
7LIC_FILES_CHKSUM = "file://zlib.h;beginline=6;endline=23;md5=5377232268e952e9ef63bc555f7aa6c0"
8
Patrick Williams03907ee2022-05-01 06:28:52 -05009SRC_URI = "https://zlib.net/${BP}.tar.xz \
10 file://cc.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011 file://ldflags-tests.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +000012 file://0001-configure-Pass-LDFLAGS-to-link-tests.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013 file://run-ptest \
Patrick Williams03907ee2022-05-01 06:28:52 -050014 file://0001-Correct-incorrect-inputs-provided-to-the-CRC-functio.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050015 file://0001-Fix-a-bug-when-getting-a-gzip-header-extra-field-wit.patch \
16 file://0001-Fix-extra-field-processing-bug-that-dereferences-NUL.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017 "
18UPSTREAM_CHECK_URI = "http://zlib.net/"
19
Patrick Williams03907ee2022-05-01 06:28:52 -050020SRC_URI[sha256sum] = "7db46b8d7726232a621befaab4a1c870f00a90805511c0e0090441dac57def18"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021
22CFLAGS += "-D_REENTRANT"
23
Patrick Williams213cb262021-08-07 19:21:33 -050024RDEPENDS:${PN}-ptest += "make"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025
26inherit ptest
27
28do_configure() {
Brad Bishop19323692019-04-05 15:28:33 -040029 LDCONFIG=true ./configure --prefix=${prefix} --shared --libdir=${libdir} --uname=GNU
Brad Bishop6e60e8b2018-02-01 10:27:11 -050030}
31
32do_compile() {
33 oe_runmake shared
34}
35
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036do_install() {
37 oe_runmake DESTDIR=${D} install
38}
39
40do_install_ptest() {
Brad Bishop19323692019-04-05 15:28:33 -040041 install ${B}/examplesh ${D}${PTEST_PATH}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050042}
43
Brad Bishop6e60e8b2018-02-01 10:27:11 -050044BBCLASSEXTEND = "native nativesdk"