blob: 0525b4135af594131d1bd8fa91619565e8453547 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001require wireguard.inc
2
Andrew Geisslerf103a7f2021-05-07 16:09:40 -05003SRCREV = "122f06bfd8fc7b06a0899fa9adc4ce8e06900d98"
Andrew Geissler82c905d2020-04-13 13:39:40 -05004
5SRC_URI = "git://git.zx2c4.com/wireguard-linux-compat"
6
7inherit module kernel-module-split
8
9DEPENDS = "virtual/kernel libmnl"
10
11# This module requires Linux 3.10 higher and several networking related
12# configuration options. For exact kernel requirements visit:
13# https://www.wireguard.io/install/#kernel-requirements
14
15EXTRA_OEMAKE_append = " \
16 KERNELDIR=${STAGING_KERNEL_DIR} \
17 "
18
19MAKE_TARGETS = "module"
20
21RRECOMMENDS_${PN} = "kernel-module-xt-hashlimit"
22MODULE_NAME = "wireguard"
23
Andrew Geissler82c905d2020-04-13 13:39:40 -050024module_do_install() {
25 install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
26 install -m 0644 ${MODULE_NAME}.ko \
27 ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
28}
Andrew Geisslerd688a012020-09-18 13:36:00 -050029
30# WireGuard has been merged into Linux kernel >= 5.6 and therefore this compatibility module is no longer required.
31# OE-core post dunfell has moved to use kernel 5.8 which now means we cant build this module in world builds
32# for reference machines e.g. qemu
33EXCLUDE_FROM_WORLD = "1"
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050034