blob: 925f188cde6d524e08e8472c6222f4b73b66e5d0 [file] [log] [blame]
Brad Bishop1fdf4aa2019-09-09 14:56:41 -04001SUMMARY = "Network scanning and manipulation tool"
2DESCRIPTION = "Scapy is a powerful interactive packet manipulation program. It is able to forge or decode packets of a wide number of protocols, send them on the wire, capture them, match requests and replies, and much more. It can easily handle most classical tasks like scanning, tracerouting, probing, unit tests, attacks or network discovery (it can replace hping, 85% of nmap, arpspoof, arp-sk, arping, tcpdump, tethereal, p0f, etc.). It also performs very well at a lot of other specific tasks that most other tools can't handle, like sending invalid frames, injecting your own 802.11 frames, combining technics (VLAN hopping+ARP cache poisoning, VOIP decoding on WEP encrypted channel, ...), etc."
3SECTION = "security"
4LICENSE = "GPLv2"
Brad Bishop19323692019-04-05 15:28:33 -04005
Brad Bishop1fdf4aa2019-09-09 14:56:41 -04006LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8S = "${WORKDIR}/git"
9
10SRCREV = "3047580162a9407ef05fe981983cacfa698f1159"
11SRC_URI = "git://github.com/secdev/scapy.git \
12 file://run-ptest"
13
14S = "${WORKDIR}/git"
15
16inherit setuptools3 ptest
Brad Bishop19323692019-04-05 15:28:33 -040017
Brad Bishop15ae2502019-06-18 21:44:24 -040018do_install_append() {
19 mv ${D}${bindir}/scapy ${D}${bindir}/scapy3
20 mv ${D}${bindir}/UTscapy ${D}${bindir}/UTscapy3
21}
Brad Bishop1fdf4aa2019-09-09 14:56:41 -040022
23do_install_ptest() {
24 install -m 0644 ${S}/test/regression.uts ${D}${PTEST_PATH}
25 sed -i 's,@PTEST_PATH@,${PTEST_PATH},' ${D}${PTEST_PATH}/run-ptest
26}
27
28RDEPENDS_${PN} = "tcpdump ${PYTHON_PN}-compression ${PYTHON_PN}-cryptography ${PYTHON_PN}-netclient \
29 ${PYTHON_PN}-netserver ${PYTHON_PN}-pydoc ${PYTHON_PN}-pkgutil ${PYTHON_PN}-shell \
30 ${PYTHON_PN}-threading ${PYTHON_PN}-numbers ${PYTHON_PN}-pycrypto"