blob: da649d578b213068e60df57958fb8749dafe4d89 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "libnvdimm utility library"
2DESCRIPTION = "Utility library for managing the libnvdimm \
3(non-volatile memory device) sub-system in the Linux kernel. \
4The LIBNVDIMM subsystem provides support for three types of \
5NVDIMMs, namely,PMEM, BLK, and NVDIMM devices that can \
6simultaneously support both PMEM and BLK mode access."
7HOMEPAGE = "https://git.kernel.org/cgit/linux/kernel/git/nvdimm/nvdimm.git/tree/Documentation/nvdimm/nvdimm.txt?h=libnvdimm-for-next"
8LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later & MIT & CC0-1.0"
9LIC_FILES_CHKSUM = "file://COPYING;md5=74a614eac8b2657a4b8e6607421a0883"
10
11inherit meson pkgconfig bash-completion systemd
12
13SRCREV = "dd58d43458943d20ff063850670bf54a5242c9c5"
14SRC_URI = "git://github.com/pmem/ndctl.git;branch=main;protocol=https \
15 file://0001-util-Correct-path-to-iniparser.h.patch \
Patrick Williams58776372022-04-13 09:07:35 -050016 file://0001-meson-Use-pkg-config-to-detect-iniparser.patch \
17 file://0001-build-set-HAVE_STATEMENT_EXPR-var.patch"
Andrew Geissler9aee5002022-03-30 16:27:02 +000018
19UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>v\d+(\.\d+)*)"
20
21DEPENDS = "kmod udev json-c keyutils iniparser"
22
23S = "${WORKDIR}/git"
24
25EXTRA_OECONF += "-Ddestructive=enabled"
26
27PACKAGECONFIG ??= "tests ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
28PACKAGECONFIG[systemd] = "-Dsystemd=enabled,-Dsystemd=disabled,systemd"
29PACKAGECONFIG[tests] = "-Dtest=enabled, -Dtest=disabled,"
30PACKAGECONFIG[docs] = "-Ddocs=enabled -Dasciidoctor=enabled,-Ddocs=disabled -Dasciidoctor=disabled, asciidoc-native"
31
32SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}"
33SYSTEMD_SERVICE:${PN} = "ndctl-monitor.service daxdev-reconfigure@.service"
34SYSTEMD_AUTO_ENABLE:${PN} = "disable"
35
36FILES:${PN} += "${datadir}/daxctl/daxctl.conf "