blob: 2817be7c861b5f4581ec1dfea82127aa7e16166d [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "YANG data modeling language library"
2DESCRIPTION = "libyang is a YANG data modelling language parser and toolkit written (and providing API) in C."
3HOMEPAGE = "https://github.com/CESNET/libyang"
4SECTION = "libs"
5LICENSE = "BSD-3-Clause"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=f3916d7d8d42a6508d0ea418cfff10ad"
8
9SRCREV = "a0cc89516ab5eca84d01c85309f320a94752a64c"
10
11SRC_URI = "git://github.com/CESNET/libyang.git;branch=master;protocol=https \
12 file://libyang-add-stdint-h.patch \
13 file://run-ptest \
14 "
15
16S = "${WORKDIR}/git"
17
18# Due to valgrind not supported on these arches:
19COMPATIBLE_HOST:riscv32 = "null"
20COMPATIBLE_HOST:armv5 = "null"
21COMPATIBLE_HOST:riscv64 = "null"
22
23# Main dependencies
Patrick Williams58776372022-04-13 09:07:35 -050024inherit cmake pkgconfig lib_package ptest
Andrew Geissler9aee5002022-03-30 16:27:02 +000025DEPENDS = "libpcre2"
26DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'cmocka', '', d)}"
Andrew Geissler9aee5002022-03-30 16:27:02 +000027
28# Ptest dependencies
29RDEPENDS:${PN}-ptest += "valgrind"
30
31EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release"
32EXTRA_OECMAKE += " ${@bb.utils.contains('PTEST_ENABLED', '1', '-DENABLE_TESTS=ON', '', d)}"
33
34do_install_ptest () {
35 cp -fR ${B}/tests/ ${D}${PTEST_PATH}/
36}
37