blob: 3875f0f605f1726c820eaea444dd67347dd0b29e [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "nicstat is a Solaris and Linux command-line that prints out network \
2statistics for all network interface cards (NICs), including packets, kilobytes \
3per second, average packet sizes and more."
4HOMEPAGE = "http://nicstat.sourceforge.net"
5LICENSE = "Artistic-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b4a94da2a1f918b217ef5156634fc9e0"
7
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008SRC_URI = "http://softlayer-sng.dl.sourceforge.net/project/${BPN}/${BP}.tar.gz \
9 file://0001-nicstat.c-Do-not-define-uint64_t-and-uint32_t.patch \
10 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011SRC_URI[md5sum] = "9a0b87bbc670c1e738e5b40c7afd184d"
12SRC_URI[sha256sum] = "c4cc33f8838f4523f27c3d7584eedbe59f4c587f0821612f5ac2201adc18b367"
13
14do_compile() {
15 ${CC} ${CFLAGS} ${LDFLAGS} -o nicstat nicstat.c
16}
17do_install() {
18 install -d ${D}/${bindir}/
19 install -d ${D}/${mandir}/
20 install -m 0755 ${S}/nicstat ${D}${bindir}/
21 install -m 0644 ${S}/nicstat.1 ${D}/${mandir}/
22}