blob: 24a7047703be7d2a53fa7def777d3e9252a91231 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions"
2DESCRIPTION = "\
3Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \
4intentions. And before you ask: It’s BSD licensed!"
5HOMEPAGE = "https://github.com/mitsuhiko/flask/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
8
Patrick Williams58776372022-04-13 09:07:35 -05009SRC_URI[sha256sum] = "a8c9bd3e558ec99646d177a9739c41df1ded0629480b4c8d2975412f3c9519c8"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000010
11PYPI_PACKAGE = "Flask"
12
13inherit pypi setuptools3
14
15CLEANBROKEN = "1"
16
17RDEPENDS:${PN} = " \
18 ${PYTHON_PN}-werkzeug \
19 ${PYTHON_PN}-jinja2 \
20 ${PYTHON_PN}-itsdangerous \
21 ${PYTHON_PN}-click \
22 ${PYTHON_PN}-profile \
23"