blob: 1d0f5995c163f44d7ff80422e6cd4b8053af7733 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013 file://add-with-bisonlocaledir.patch \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050014 file://0001-bison-fix-the-parallel-build.patch \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050015 "
Andrew Geissler5a43b432020-06-13 10:46:56 -050016SRC_URI[sha256sum] = "06db793651de9dd5f0a85a6fe4bdbca413c0806bf2432377523da96ca0b4b73d"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18# No point in hardcoding path to m4, just use PATH
19EXTRA_OECONF += "M4=m4"
20
21# Reset any loadavg set via environment, it breaks parallel build
22# | ../bison-3.5.2/lib/uniwidth/width.c:21:10: fatal error: uniwidth.h: No such file or directory
23# | #include "uniwidth.h"
24# | ^~~~~~~~~~~~
25EXTRA_OEMAKE_append = " -l"
26
27inherit autotools gettext texinfo
28
29# The automatic m4 path detection gets confused, so force the right value
30acpaths = "-I ${S}/m4"
31
32do_compile_prepend() {
33 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
34}
35
36do_install_append_class-native() {
37 create_wrapper ${D}/${bindir}/bison \
38 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
39}
40do_install_append_class-nativesdk() {
41 create_wrapper ${D}/${bindir}/bison \
42 BISON_PKGDATADIR=${datadir}/bison
43}
44BBCLASSEXTEND = "native nativesdk"