blob: 81f1cfec5db2a4d0758931245d7da1fe285bc887 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Distributed block device driver for Linux"
2DESCRIPTION = "DRBD mirrors a block device over the network to another machine.\
3DRBD mirrors a block device over the network to another machine.\
4Think of it as networked raid 1. It is a building block for\
5setting up high availability (HA) clusters."
6HOMEPAGE = "http://www.drbd.org/"
7SECTION = "admin"
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
10
Brad Bishop316dfdd2018-06-25 12:45:53 -040011SRC_URI = "http://www.linbit.com/downloads/drbd/utils/archive/${BP}.tar.gz \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050012 file://0001-Makefile.in-fix-permission-bits-for-drbd.service.patch \
13 "
Patrick Williamsddad1a12017-02-23 20:36:32 -060014SRC_URI[md5sum] = "76ed6d3190cd77b00890f3365353124b"
15SRC_URI[sha256sum] = "297b77c9b3f88de2e7dae459234f2753ea4fc2805282b2d276e35cf51e292913"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050016
17SYSTEMD_SERVICE_${PN} = "drbd.service"
18SYSTEMD_AUTO_ENABLE = "disable"
19
20inherit autotools-brokensep systemd
21
22EXTRA_OECONF = " \
23 --with-initdir=/etc/init.d \
24 --without-pacemaker \
25 --without-rgmanager \
26 --without-bashcompletion \
27 --with-distro debian \
28 --with-initscripttype=both \
29 --with-systemdunitdir=${systemd_unitdir}/system \
Patrick Williamsddad1a12017-02-23 20:36:32 -060030 --without-manual\
Patrick Williamsb48b7b42016-08-17 15:04:38 -050031 "
32
Brad Bishop6e60e8b2018-02-01 10:27:11 -050033do_install_append() {
34 # don't install empty /var/lock to avoid conflict with base-files
35 rm -rf ${D}${localstatedir}/lock
36}
37
38RDEPENDS_${PN} += "bash perl-module-getopt-long perl-module-exporter perl-module-constant perl-module-overloading perl-module-exporter-heavy"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050039
40# The drbd items are explicitly put under /lib when installed.
41#
42FILES_${PN} += "/run"
43FILES_${PN} += "${nonarch_base_libdir}/drbd \
44 ${nonarch_libdir}/drbd \
45 ${nonarch_libdir}/tmpfiles.d"
46FILES_${PN}-dbg += "${nonarch_base_libdir}/drbd/.debug"