blob: 95147bdad21a18baf02fb8d234f5cf123017cdba [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001#
2# Copyright (C) 2014, 2015 Wind River Systems, Inc.
3# Released under the MIT license (see COPYING.MIT for the terms)
4#
5SUMMARY = "GeoIP perl API library to access location database"
6DESCRIPTION = "perl library for country/city/organization to IP address or hostname mapping"
7HOMEPAGE = "http://www.maxmind.com/app/ip-location"
8SECTION = "libdevel"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
Patrick Williamsddad1a12017-02-23 20:36:32 -060010LIC_FILES_CHKSUM = "file://LICENSE;md5=b7a36f55e8ba62aadd74e4f0886a405e"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011
Brad Bishop316dfdd2018-06-25 12:45:53 -040012S = "${WORKDIR}/git"
13SRCREV = "47f7d49bd15cfc2e5f8c0f5c4068dc8bb0e10e96"
14SRC_URI = "git://github.com/maxmind/geoip-api-perl.git;protocol=https; \
Patrick Williamsddad1a12017-02-23 20:36:32 -060015 file://run-ptest \
16"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018DEPENDS += "geoip"
19
20inherit cpan ptest
21
22EXTRA_CPANFLAGS = "LIBS='-L${STAGING_LIBDIR}' INC='-I${STAGING_INCDIR}'"
23
24
25# perl scripts and some special small data files
26#
27do_install_ptest () {
Patrick Williamsddad1a12017-02-23 20:36:32 -060028 install -d -m 0755 ${D}${PTEST_PATH}/t/data
Patrick Williamsb48b7b42016-08-17 15:04:38 -050029
Patrick Williamsddad1a12017-02-23 20:36:32 -060030 install ${S}/t/*.t* ${D}${PTEST_PATH}/t
31 install ${S}/t/data/* ${D}${PTEST_PATH}/t/data
Patrick Williamsb48b7b42016-08-17 15:04:38 -050032}
33
34FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/Geo/IP/.debug"
35