blob: b35a9f4a4058064b739fd6f82423ade2ca8c43a4 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Linux Virtual Server administration Utility"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "http://www.linux-vs.org/software/index.html"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05003DESCRIPTION = "Ipvsadm is used to set up, maintain or inspect the virtual server \
4table in the Linux kernel. The Linux Virtual Server can be used to \
5build scalable network services based on a cluster of two or more nodes. \
6The active node of the cluster redirects service requests to a \
7collection of server hosts that will actually perform the services. \
8Supported features include two protocols (TCP and UDP), three packet-forwarding \
9methods (NAT, tunneling, and direct routing), and eight load balancing algorithms \
10(round robin, weighted round robin, least-connec-tion, weighted least-connection, \
11locality-based least-connection, locality-based least-connection with replication, \
12destination-hashing, and source-hashing)."
13SECTION = "net"
14LICENSE = "GPL-2.0"
15LIC_FILES_CHKSUM = "file://README;beginline=40;endline=56;md5=a54cba37b64924aa5008881607942892"
16
17DEPENDS += "libnl popt"
18
19SRC_URI = "http://www.linuxvirtualserver.org/software/kernel-2.6/${BP}.tar.gz \
20 file://0001-Modify-the-Makefile-for-cross-compile.patch \
21 file://0002-Replace-nl_handle-to-nl_sock.patch \
22 file://0003-ipvsadm-remove-dependency-on-bash.patch \
Patrick Williamsddad1a12017-02-23 20:36:32 -060023 file://makefile-add-ldflags.patch \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050024"
25
26SRC_URI[md5sum] = "eac3ba3f62cd4dea2da353aeddd353a8"
27SRC_URI[sha256sum] = "6d6c46fecb1c532a892616b4445c73b71730e8790d5630f60269fd9cbee0eb2d"
28
29do_compile() {
30 oe_runmake \
31 CC="${CC} -I${STAGING_INCDIR} -I${STAGING_INCDIR}/libnl3 -L${STAGING_LIBDIR}" \
32 all
33}
34
35do_install() {
36 oe_runmake 'BUILD_ROOT=${D}' install
37}