blob: 0c120bfd84e701a92288f25ec9aca7a39bb84049 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Mobile IPv6 and NEMO for Linux"
2DESCRIPTION = "UMIP is an open source implementation of Mobile IPv6 and NEMO \
3Basic Support for Linux. It is released under the GPLv2 license. It supports \
4the following IETF RFC: RFC6275 (Mobile IPv6), RFC3963 (NEMO), RFC3776 and \
5RFC4877 (IPsec and IKEv2)."
6HOMEPAGE = "http://umip.org/"
7SECTION = "System Environment/Base"
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=073dc31ccb2ebed70db54f1e8aeb4c33"
10DEPENDS = "rpm indent-native"
11
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012SRC_URI = "git://github.com/jlanza/umip \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013 file://add-dependency-to-support-parallel-compilation.patch \
14 file://mip6d \
15 file://mip6d.service \
16 file://0001-Add-format-string-to-fprintf-call.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040017 file://0001-replace-SIGCLD-with-SIGCHLD-and-include-sys-types.h.patch \
18 file://0002-replace-PTHREAD_MUTEX_FAST_NP-with-PTHREAD_MUTEX_NOR.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020SRCREV = "7d67209cd1bba2dd0e183a0fa07eeef07964dd14"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050021
22S = "${WORKDIR}/git"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050023
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024EXTRA_OECONF = "--enable-vt"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050025
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026inherit autotools-brokensep systemd update-rc.d
27
28INITSCRIPT_NAME = "mip6d"
29INITSCRIPT_PARAMS = "start 64 . stop 36 0 1 2 3 4 5 6 ."
30
31SYSTEMD_SERVICE_${PN} = "mip6d.service"
32SYSTEMD_AUTO_ENABLE = "disable"
33
34do_install_append() {
35 install -D -m 0755 ${WORKDIR}/mip6d ${D}${sysconfdir}/init.d/mip6d
36 install -D -m 0644 ${WORKDIR}/mip6d.service ${D}${systemd_system_unitdir}/mip6d.service
37 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' \
38 -e 's,@SBINDIR@,${sbindir},g' \
39 ${D}${systemd_system_unitdir}/mip6d.service
40}
41
42RRECOMMENDS_${PN} = "kernel-module-mip6 kernel-module-ipv6"