blob: f34928fe3a860ef3d8f5f733e6a45f69733d4960 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "PolicyKit Authorization Framework"
2DESCRIPTION = "The polkit package is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/polkit"
4LICENSE = "LGPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
6 file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4"
7
8DEPENDS = "expat glib-2.0 intltool-native mozjs"
9
10inherit autotools gtk-doc pkgconfig useradd systemd gobject-introspection
11
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', \
14 bb.utils.contains('DISTRO_FEATURES', 'x11', 'consolekit', '', d), d)} \
15 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050016
17PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=shadow,libpam,libpam"
18PACKAGECONFIG[systemd] = "--enable-libsystemd-login=yes --with-systemdsystemunitdir=${systemd_unitdir}/system/,--enable-libsystemd-login=no --with-systemdsystemunitdir=,systemd"
19# there is no --enable/--disable option for consolekit and it's not picked by shlibs, so add it to RDEPENDS
20PACKAGECONFIG[consolekit] = ",,,consolekit"
21
22PAM_SRC_URI = "file://polkit-1_pam.patch"
23SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.gz \
Patrick Williamsddad1a12017-02-23 20:36:32 -060024 file://0001-make-netgroup-support-configurable.patch \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050026"
27SRC_URI[md5sum] = "4b77776c9e4f897dcfe03b2c34198edf"
28SRC_URI[sha256sum] = "e1c095093c654951f78f8618d427faf91cf62abdefed98de40ff65eca6413c81"
29
30EXTRA_OECONF = "--with-os-type=moblin --disable-man-pages"
31
32do_compile_prepend () {
Patrick Williamsddad1a12017-02-23 20:36:32 -060033 export GIR_EXTRA_LIBS_PATH="${B}/src/polkit/.libs"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050034}
35
36PACKAGES =+ "${PN}-examples"
37
38FILES_${PN}_append = " \
39 ${libdir}/${BPN}-1 \
40 ${nonarch_libdir}/${BPN}-1 \
41 ${datadir}/dbus-1 \
42 ${datadir}/${BPN}-1 \
43"
44
45FILES_${PN}-examples = "${bindir}/*example*"
46
47USERADD_PACKAGES = "${PN}"
48USERADD_PARAM_${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/${BPN}-1 polkitd"
49
50SYSTEMD_SERVICE_${PN} = "${BPN}.service"
51SYSTEMD_AUTO_ENABLE = "disable"