blob: 79e7dc599855fa5579b28bf2fe112574e80e8bee [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
2HOMEPAGE = "http://www.libssh.org"
3SECTION = "libs"
4
5DEPENDS = "zlib openssl libgcrypt"
6
7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
9
10SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=v0-7"
Patrick Williamsddad1a12017-02-23 20:36:32 -060011SRCREV = "cdf7690e038230623cbbf6b024ece62f41efa98d"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050012S = "${WORKDIR}/git"
13
14EXTRA_OECMAKE = " \
15 -DWITH_GCRYPT=1 \
16 -DWITH_PCAP=1 \
17 -DWITH_SFTP=1 \
18 -DWITH_ZLIB=1 \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019 -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020 "
21
22PACKAGECONFIG ??=""
23PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
24
25inherit cmake
26
27do_configure_prepend () {
28 # Disable building of examples
29 sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
30 || bbfatal "Failed to disable examples"
31}
32
33FILES_${PN}-dev += "${libdir}/cmake"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050034TOOLCHAIN = "gcc"