blob: 68f0387ba977cb6e810327e7f7720d2c2dc5e9a9 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Synergy - control multiple computers with one keyboard and mouse"
2HOMEPAGE = "http://synergy-project.org"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05003LIC_FILES_CHKSUM = "file://LICENSE;md5=d2ba51ca68e055566aade24662f9eb41"
4LICENSE = "GPL-2.0-with-OpenSSL-exception"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05005SECTION = "x11/utils"
6
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007DEPENDS = "virtual/libx11 libxtst libxinerama curl openssl"
8do_unpack_extra[depends] = "unzip-native:do_populate_sysroot"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05009
10# depends on virtual/libx11
11REQUIRED_DISTRO_FEATURES = "x11"
12
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013SRC_URI = "git://github.com/symless/synergy.git;protocol=http"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050014
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015# Version 1.8.8-stable
16SRCREV ?= "c30301e23424db1125664da17deb8c3aa6aec52d"
17PV = "1.8.8+${SRCPV}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018
19S = "${WORKDIR}/git"
20
21inherit cmake distro_features_check
22
23do_unpack_extra() {
24 cd ${S}/ext
25 for file in *.zip; do
26 fname="${file##*/}"
27 unzip $file -d ${fname%.*}
28 done
29}
30addtask unpack_extra after do_unpack before do_patch
31
32do_install() {
33 install -d ${D}/usr/bin
34 install -m 0755 ${S}/bin/synergy* ${D}/usr/bin/
35}