blob: f8b7b06cf24a441f2d59d2ecbcdd7660a5078ac0 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Tool to produce a statistics based on a diff"
2DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \
3the insertions, deletions, and modifications per-file. It is useful for \
4reviewing large, complex patch files."
5HOMEPAGE = "http://invisible-island.net/diffstat/"
6SECTION = "devel"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://install-sh;endline=42;md5=b3549726c1022bee09c174c72a0ca4a5"
9
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050011 file://run-ptest \
12"
13
14SRC_URI[md5sum] = "c048a32d55d8bd6724f382baf41f325f"
15SRC_URI[sha256sum] = "25359e0c27183f997b36c9202583b5dc2df390c20e22a92606af4bf7856a55ee"
16
17S = "${WORKDIR}/diffstat-${PV}"
18
19inherit autotools gettext ptest
20
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021EXTRA_AUTORECONF += "--exclude=aclocal"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050022
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023LDFLAGS += "${TOOLCHAIN_OPTIONS}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050024
25do_install_ptest() {
26 cp -r ${S}/testing ${D}${PTEST_PATH}
27}