blob: 224428ddda5a266b84761b4e02232b50e06f3ebb [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2007-2008 OpenedHand Ltd.
3#
4
5SUMMARY = "Sato desktop"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006PR = "r33"
7
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10inherit packagegroup distro_features_check
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011REQUIRED_DISTRO_FEATURES = "x11"
12
13PACKAGES = "${PN} ${PN}-base ${PN}-apps ${PN}-games"
14
15RDEPENDS_${PN} = "\
16 ${PN}-base \
17 ${PN}-apps \
18 ${PN}-games \
19 "
20
21NETWORK_MANAGER ?= "connman-gnome"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022
23SUMMARY_${PN}-base = "Sato desktop - base packages"
24RDEPENDS_${PN}-base = "\
25 matchbox-desktop \
26 matchbox-session-sato \
27 matchbox-keyboard \
28 matchbox-keyboard-applet \
29 matchbox-keyboard-im \
30 matchbox-config-gtk \
31 xcursor-transparent-theme \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060032 adwaita-icon-theme \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033 settings-daemon \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034 shutdown-desktop \
35 libsdl \
36 ${NETWORK_MANAGER} \
37 udev-extraconf \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050038 ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-server pulseaudio-client-conf-sato pulseaudio-misc', '', d)} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039 "
40
Patrick Williamsc124f4f2015-09-15 14:41:29 -050041FILEMANAGER ?= "pcmanfm"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050042
43WEB ?= ""
44#WEB = "epiphany"
45
46SUMMARY_${PN}-apps = "Sato desktop - applications"
47RDEPENDS_${PN}-apps = "\
Patrick Williamsc0f7c042017-02-23 20:41:17 -060048 l3afpad \
Brad Bishop316dfdd2018-06-25 12:45:53 -040049 gst-examples \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050050 matchbox-terminal \
51 sato-screenshot \
52 ${FILEMANAGER} \
53 ${WEB} \
54 "
55
56SUMMARY_${PN}-games = "Sato desktop - games"
57RDEPENDS_${PN}-games = "\
Patrick Williamsc0f7c042017-02-23 20:41:17 -060058 puzzles \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050059 "