blob: 57798f402010bd4b482ff5624cf53b6f1849df0d [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Provides a way to load and enumerate PKCS#11 modules"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50"
4
Brad Bishop00111322018-04-01 22:23:53 -04005inherit autotools gettext pkgconfig gtk-doc
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006
7DEPENDS = "libtasn1 libffi"
8
Brad Bishop00111322018-04-01 22:23:53 -04009SRC_URI = "git://github.com/p11-glue/p11-kit \
10 file://0001-LINGUAS-drop-the-languages-for-which-upstream-does-n.patch \
11 "
12SRCREV = "bfb3bd47aa48983f5349479bca598403097ff81c"
13S = "${WORKDIR}/git"
14# exclude odd minor versions, which are development releases
15UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016
Brad Bishop00111322018-04-01 22:23:53 -040017AUTOTOOLS_AUXDIR = "${S}/build/litter"
Patrick Williamsf1e5d692016-03-30 15:21:19 -050018EXTRA_OECONF = "--without-trust-paths"
19
Patrick Williamsc0f7c042017-02-23 20:41:17 -060020# This recipe does not use the standard gtk-doc m4 macros, and so the ./configure flags
21# that control gtk-doc build are non-standard
22EXTRA_OECONF_prepend_class-target = "${@bb.utils.contains('GTKDOC_ENABLED', 'True', '--enable-doc --enable-doc-html --disable-doc-pdf', \
23 '--disable-doc', d)} "
24
25# When building native recipes, disable gtkdoc, as it is not necessary,
26# pulls in additional dependencies, and makes build times longer
27EXTRA_OECONF_prepend_class-native = "--disable-doc "
28EXTRA_OECONF_prepend_class-nativesdk = "--disable-doc "
29
30UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-gtk-doc-html --disable-gtk-doc-pdf --enable-gtk-doc --disable-gtk-doc"
31
32# p11-kit relies on these two being copied from source tree
33# instead of being regenerated by gtkdoc-scan, but doesn't setup
34# dependencies correctly when there is a parallel build. Let's pre-copy
35# them instead.
36do_compile_prepend () {
37 cp ${S}/doc/manual/p11-kit-overrides.txt ${S}/doc/manual/p11-kit-sections.txt ${B}/doc/manual/
38}
39
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050040FILES_${PN} += " \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050041 ${libdir}/p11-kit-proxy.so \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050042 ${libdir}/pkcs11/*.so \
43 ${libdir}/pkcs11/*.la"
44
45# PN contains p11-kit-proxy.so, a symlink to a loadable module
46INSANE_SKIP_${PN} = "dev-so"