blob: ce2dac0a55086faaf50e5102c52ee24d92cfe8ff [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "A PKCS#11 interface for TPM2 hardware"
2DESCRIPTION = "PKCS #11 is a Public-Key Cryptography Standard that defines a standard method to access cryptographic services from tokens/ devices such as hardware security modules (HSM), smart cards, etc. In this project we intend to use a TPM2 device as the cryptographic token."
3SECTION = "security/tpm"
4LICENSE = "BSD-2-Clause"
Andrew Geissler064f75b2020-06-27 00:14:46 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=0fc19f620a102768d6dbd1e7166e78ab"
Brad Bishop19323692019-04-05 15:28:33 -04006
Andrew Geissler064f75b2020-06-27 00:14:46 -05007DEPENDS = "autoconf-archive pkgconfig dstat sqlite3 openssl libtss2-dev tpm2-tools libyaml"
Brad Bishop19323692019-04-05 15:28:33 -04008
Andrew Geissler064f75b2020-06-27 00:14:46 -05009SRC_URI = "git://github.com/tpm2-software/tpm2-pkcs11.git;branch=1.X \
10 file://bootstrap_fixup.patch "
Brad Bishop19323692019-04-05 15:28:33 -040011
Andrew Geissler064f75b2020-06-27 00:14:46 -050012SRCREV = "8d8f137f65f1d61d66cc191947b59c378f23e97d"
Brad Bishop19323692019-04-05 15:28:33 -040013
14S = "${WORKDIR}/git"
15
16inherit autotools-brokensep pkgconfig
17
18do_configure_prepend () {
19 ${S}/bootstrap
20}