blob: aab319be91af7f559764b4dc4663164a8bd32286 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Tools to manipulate UEFI variables"
2DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
3HOMEPAGE = "https://github.com/rhboot/efivar"
4
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "LGPL-2.1-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +00006LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393"
7
8COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
9
10SRC_URI = "git://github.com/rhinstaller/efivar.git;branch=main;protocol=https \
11 file://0001-docs-do-not-build-efisecdb-manpage.patch \
Andrew Geissler595f6302022-01-24 19:11:47 +000012 "
Patrick Williams39653562024-03-01 08:54:02 -060013SRCREV = "c47820c37ac26286559ec004de07d48d05f3308c"
Andrew Geissler5082cc72023-09-11 08:41:39 -040014PV .= "+39+git"
Andrew Geissler595f6302022-01-24 19:11:47 +000015
16S = "${WORKDIR}/git"
17
18inherit pkgconfig
19
20export CCLD_FOR_BUILD = "${BUILD_CCLD}"
21
Andrew Geissler595f6302022-01-24 19:11:47 +000022do_compile() {
23 oe_runmake ERRORS= HOST_CFLAGS="${BUILD_CFLAGS}" HOST_LDFLAGS="${BUILD_LDFLAGS}"
24}
25
26do_install() {
27 oe_runmake install DESTDIR=${D}
28}
29
30BBCLASSEXTEND = "native"
31
32RRECOMMENDS:${PN}:class-target = "kernel-module-efivarfs"
33
34CLEANBROKEN = "1"