Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "RenderDoc recipe providing renderdoccmd" |
| 2 | DESCRIPTION = "RenderDoc is a frame-capture based graphics debugger" |
| 3 | HOMEPAGE = "https://github.com/baldurk/renderdoc" |
| 4 | LICENSE = "MIT" |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=5486c0df458c74c85828e0cdbffd499e" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 6 | |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 7 | SRCREV = "cc05b288b6d1660ab04c6cf01173f1bb62e6f5dd" |
| 8 | SRC_URI = " \ |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 9 | git://github.com/baldurk/${BPN}.git;protocol=https;branch=v1.x \ |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 10 | file://0001-renderdoc-use-xxd-instead-of-cross-compiling-shim-bi.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | " |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | DEPENDS += "virtual/libx11 virtual/libgl libxcb xcb-util-keysyms vim-native" |
| 15 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 16 | RDEPENDS:${PN} = "libxcb xcb-util-keysyms" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 18 | inherit cmake pkgconfig python3native features_check |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | |
| 20 | REQUIRED_DISTRO_FEATURES = "x11 opengl" |
| 21 | |
| 22 | python __anonymous () { |
| 23 | # only works on glibc systems |
| 24 | if d.getVar('TCLIBC') != "glibc": |
| 25 | raise bb.parse.SkipRecipe("incompatible with %s C library" % d.getVar('TCLIBC')) |
| 26 | } |
| 27 | |
| 28 | COMPATIBLE_HOST = "(x86_64|i.86|arm|aarch64).*-linux" |
| 29 | |
| 30 | EXTRA_OECMAKE += "\ |
| 31 | -DENABLE_QRENDERDOC=OFF \ |
| 32 | -DENABLE_PYRENDERDOC=OFF \ |
| 33 | -DENABLE_RENDERDOCCMD=ON \ |
| 34 | -DCMAKE_BUILD_TYPE=Release \ |
| 35 | " |
| 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | FILES:${PN} += "${libdir}" |
| 38 | FILES:${PN}-dev = "${includedir}" |