blob: 2d1e92966ff72f033aca74a2d32014cd6cc85cd4 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "XML C Parser Library and Toolkit"
2DESCRIPTION = "The XML Parser Library allows for manipulation of XML files. Libxml2 exports Push and Pull type parser interfaces for both XML and HTML. It can do DTD validation at parse time, on a parsed document instance or with an arbitrary DTD. Libxml2 includes complete XPath, XPointer and Xinclude implementations. It also has a SAX like interface, which is designed to be compatible with Expat."
3HOMEPAGE = "http://www.xmlsoft.org/"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml2"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
William A. Kennington IIIac69b482021-06-02 12:28:27 -07008 file://hash.c;beginline=6;endline=15;md5=e77f77b12cb69e203d8b4090a0eee879 \
9 file://list.c;beginline=4;endline=13;md5=b9c25b021ccaf287e50060602d20f3a7 \
10 file://trio.c;beginline=5;endline=14;md5=cd4f61e27f88c1d43df112966b1cd28f"
Andrew Geissler82c905d2020-04-13 13:39:40 -050011
12DEPENDS = "zlib virtual/libiconv"
13
14SRC_URI = "http://www.xmlsoft.org/sources/libxml2-${PV}.tar.gz;name=libtar \
15 http://www.w3.org/XML/Test/xmlts20080827.tar.gz;subdir=${BP};name=testtar \
16 file://libxml-64bit.patch \
17 file://runtest.patch \
18 file://run-ptest \
19 file://python-sitepackages-dir.patch \
20 file://libxml-m4-use-pkgconfig.patch \
21 file://0001-Make-ptest-run-the-python-tests-if-python-is-enabled.patch \
22 file://fix-execution-of-ptests.patch \
William A. Kennington IIIac69b482021-06-02 12:28:27 -070023 file://remove-fuzz-from-ptests.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050024 "
25
William A. Kennington IIIac69b482021-06-02 12:28:27 -070026SRC_URI[libtar.sha256sum] = "c8d6681e38c56f172892c85ddc0852e1fd4b53b4209e7f4ebf17f7e2eae71d92"
Andrew Geissler82c905d2020-04-13 13:39:40 -050027SRC_URI[testtar.sha256sum] = "96151685cec997e1f9f3387e3626d61e6284d4d6e66e0e440c209286c03e9cc7"
28
29BINCONFIG = "${bindir}/xml2-config"
30
31PACKAGECONFIG ??= "python \
32 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
33"
34PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python3"
35PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
36
Andrew Geissler5a43b432020-06-13 10:46:56 -050037inherit autotools pkgconfig binconfig-disabled ptest
Andrew Geissler82c905d2020-04-13 13:39:40 -050038
39inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
40
William A. Kennington IIIac69b482021-06-02 12:28:27 -070041RDEPENDS_${PN}-ptest += "bash make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050042
43RDEPENDS_${PN}-python += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}"
44
45RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-gconv-ebcdic-us \
46 glibc-gconv-ibm1141 \
47 glibc-gconv-iso8859-5 \
48 glibc-gconv-euc-jp \
49 locale-base-en-us \
50 "
51
52export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
53
54# WARNING: zlib is required for RPM use
55EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
56EXTRA_OECONF_class-native = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
57EXTRA_OECONF_class-nativesdk = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
58EXTRA_OECONF_linuxstdbase = "--with-debug --with-legacy --with-docbook --with-c14n --without-lzma --with-zlib"
59
60python populate_packages_prepend () {
61 # autonamer would call this libxml2-2, but we don't want that
62 if d.getVar('DEBIAN_NAMES'):
63 d.setVar('PKG_libxml2', '${MLPREFIX}libxml2')
64}
65
66PACKAGE_BEFORE_PN += "${PN}-utils"
67PACKAGES += "${PN}-python"
68
69FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
Andrew Geissler5f350902021-07-23 13:09:54 -040070FILES_${PN}-dev += "${libdir}/xml2Conf.sh"
Andrew Geissler82c905d2020-04-13 13:39:40 -050071FILES_${PN}-utils = "${bindir}/*"
72FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
73
74do_configure_prepend () {
75 # executables take longer to package: these should not be executable
76 find ${S}/xmlconf/ -type f -exec chmod -x {} \+
77}
78
79do_compile_ptest() {
80 oe_runmake check-am
81}
82
83do_install_ptest () {
84 cp -r ${S}/xmlconf ${D}${PTEST_PATH}
85 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
86 sed -i -e 's|^\(PYTHON = \).*|\1${USRBINPATH}/${PYTHON_PN}|' \
87 ${D}${PTEST_PATH}/python/tests/Makefile
88 grep -lrZ '#!/usr/bin/python' ${D}${PTEST_PATH}/python |
89 xargs -0 sed -i -e 's|/usr/bin/python|${USRBINPATH}/${PYTHON_PN}|'
90 fi
91 #Remove build host references from various Makefiles
92 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
93 sed -i \
94 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
95 -e 's|${DEBUG_PREFIX_MAP}||g' \
96 -e 's:${HOSTTOOLS_DIR}/::g' \
97 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
98 -e 's:${RECIPE_SYSROOT}::g' \
99 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
100 -e '/^RELDATE/d' \
101 {} +
102}
103
104do_install_append_class-native () {
105 # Docs are not needed in the native case
106 rm ${D}${datadir}/gtk-doc -rf
107}
108
109BBCLASSEXTEND = "native nativesdk"