blob: 83c9917a04f580101e4e548cf94e8367fa9ad735 [file] [log] [blame]
Andrew Geissler09036742021-06-25 14:25:14 -05001SUMMARY = "A library for property-based testing"
2HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python"
3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
5
6PYPI_PACKAGE = "hypothesis"
7
8inherit pypi setuptools3
9
Andrew Geissler5f350902021-07-23 13:09:54 -040010SRC_URI[sha256sum] = "1c8776d9fc8c598cf1b93b99bd87976f9d9b589fc58843d85a30090700f14a8a"
Andrew Geissler09036742021-06-25 14:25:14 -050011
12RDEPENDS_${PN} += " \
13 python3-attrs \
14 python3-compression \
15 python3-core \
16 python3-json \
17 python3-sortedcontainers \
18 python3-statistics \
19 python3-unittest \
20 "
21
22BBCLASSEXTEND = "native nativesdk"