blob: 972173ef50ffa57df5401d02c4fa580b27610137 [file] [log] [blame]
Andrew Geissler6ce62a22020-11-30 19:58:47 -06001DESCRIPTION = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002HOMEPAGE = "https://www.khronos.org/vulkan/"
3BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Samples/issues"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06004LICENSE = "Apache-2.0"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a"
7
8SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git \
9 file://0001-CMakeLists.txt-do-not-hardcode-lib-as-installation-t.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060010 file://debugfix.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060011 "
12
13UPSTREAM_CHECK_COMMITS = "1"
Andrew Geissler5f350902021-07-23 13:09:54 -040014SRCREV = "47c5237be21209afc945e43d03ae409fa80a0155"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060015
16UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
17S = "${WORKDIR}/git"
18
19REQUIRED_DISTRO_FEATURES = 'vulkan'
20
21inherit cmake features_check
22
23FILES_${PN} += "${datadir}"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060024
25#
26# There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths
27# used for logging with LOGE in the code. We need to make this match the value we use
28# in the debug source remapping from CFLAGS
29#
30EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/"
31# Binaries built with PCH enabled don't appear reproducible, differing results were seen
32# from some builds depending on the point the PCH was compiled. Disable it to be
33# deterministic
34EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON"