blob: 19b6ed3e58d2b30813b48f5e690721d1bc8b4752 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A portable foreign function interface library"
2HOMEPAGE = "http://sourceware.org/libffi/"
3DESCRIPTION = "The `libffi' library provides a portable, high level programming interface to various calling \
4conventions. This allows a programmer to call any function specified by a call interface description at run \
5time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the \
6interface that allows code written in one language to call code written in another language. The `libffi' \
7library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. \
8A layer must exist above `libffi' that handles type conversions for values passed between the two languages."
9
10LICENSE = "MIT"
Andrew Geissler5f350902021-07-23 13:09:54 -040011LIC_FILES_CHKSUM = "file://LICENSE;md5=679b5c9bdc79a2b93ee574e193e7a7bc"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
13SRC_URI = "https://github.com/libffi/libffi/releases/download/v${PV}/${BPN}-${PV}.tar.gz \
14 file://not-win32.patch \
Andrew Geissler09209ee2020-12-13 08:44:15 -060015 file://0001-arm-sysv-reverted-clang-VFP-mitigation.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050016 "
Andrew Geissler5f350902021-07-23 13:09:54 -040017SRC_URI[sha256sum] = "540fb721619a6aba3bdeef7d940d8e9e0e6d2c193595bc243241b77ff9e93620"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018UPSTREAM_CHECK_URI = "https://github.com/libffi/libffi/releases/"
19UPSTREAM_CHECK_REGEX = "libffi-(?P<pver>\d+(\.\d+)+)\.tar"
20
Andrew Geissler5f350902021-07-23 13:09:54 -040021EXTRA_OECONF += "--disable-builddir --disable-exec-static-tramp"
Andrew Geissler82c905d2020-04-13 13:39:40 -050022EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
23inherit autotools texinfo multilib_header
24
25do_install_append() {
Andrew Geissler635e0e42020-08-21 15:58:33 -050026 oe_multilib_header ffi.h ffitarget.h
Andrew Geissler82c905d2020-04-13 13:39:40 -050027}
28
29FILES_${PN}-dev += "${libdir}/libffi-${PV}"
30
31# Doesn't compile in MIPS16e mode due to use of hand-written
32# assembly
33MIPS_INSTRUCTION_SET = "mips"
34
35BBCLASSEXTEND = "native nativesdk"
36