blob: d73350b940175f3eb245656d13d773516017d010 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Summarize sstate usage at the end of the build
2python buildstats_summary () {
3 import collections
4 import os.path
5
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05006 bsdir = e.data.expand("${BUILDSTATS_BASE}/${BUILDNAME}")
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007 if not os.path.exists(bsdir):
8 return
9
10 sstatetasks = (e.data.getVar('SSTATETASKS', True) or '').split()
11 built = collections.defaultdict(lambda: [set(), set()])
12 for pf in os.listdir(bsdir):
13 taskdir = os.path.join(bsdir, pf)
14 if not os.path.isdir(taskdir):
15 continue
16
17 tasks = os.listdir(taskdir)
18 for t in sstatetasks:
19 no_sstate, sstate = built[t]
20 if t in tasks:
21 no_sstate.add(pf)
22 elif t + '_setscene' in tasks:
23 sstate.add(pf)
24
25 header_printed = False
26 for t in sstatetasks:
27 no_sstate, sstate = built[t]
28 if no_sstate | sstate:
29 if not header_printed:
30 header_printed = True
31 bb.note("Build completion summary:")
32
33 bb.note(" {0}: {1}% sstate reuse ({2} setscene, {3} scratch)".format(t, 100*len(sstate)/(len(sstate)+len(no_sstate)), len(sstate), len(no_sstate)))
34}
35addhandler buildstats_summary
36buildstats_summary[eventmask] = "bb.event.BuildCompleted"