blob: 91461b11e7b8a19939a04d89c0e01e0365461187 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001DEPENDS += "qemu-native"
2inherit qemu
3
4GIO_MODULE_PACKAGES ??= "${PN}"
5
6gio_module_cache_common() {
7if [ "x$D" != "x" ]; then
8 $INTERCEPT_DIR/postinst_intercept update_gio_module_cache ${PKG} \
9 mlprefix=${MLPREFIX} \
10 binprefix=${MLPREFIX} \
11 libdir=${libdir} \
12 base_libdir=${base_libdir} \
13 bindir=${bindir}
14else
15 ${libexecdir}/${MLPREFIX}gio-querymodules ${libdir}/gio/modules/
16fi
17}
18
19python populate_packages_append () {
20 packages = d.getVar('GIO_MODULE_PACKAGES', True).split()
21
22 for pkg in packages:
23 bb.note("adding gio-module-cache postinst and postrm scripts to %s" % pkg)
24
25 postinst = d.getVar('pkg_postinst_%s' % pkg, True)
26 if not postinst:
27 postinst = '#!/bin/sh\n'
28 postinst += d.getVar('gio_module_cache_common', True)
29 d.setVar('pkg_postinst_%s' % pkg, postinst)
30
31 postrm = d.getVar('pkg_postrm_%s' % pkg, True)
32 if not postrm:
33 postrm = '#!/bin/sh\n'
34 postrm += d.getVar('gio_module_cache_common', True)
35 d.setVar('pkg_postrm_%s' % pkg, postrm)
36}
37