blob: 19e4aa2e478508c0ed72a72aca1672c129d6f8d4 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001inherit image_types kernel-arch
2
3oe_mkimage () {
4 mkimage -A ${UBOOT_ARCH} -O linux -T ramdisk -C $2 -n ${IMAGE_NAME} \
5 -d ${DEPLOY_DIR_IMAGE}/$1 ${DEPLOY_DIR_IMAGE}/$1.u-boot
6 if [ x$3 = x"clean" ]; then
7 rm $1
8 fi
9}
10
11COMPRESSIONTYPES += "gz.u-boot bz2.u-boot lzma.u-boot u-boot"
12
13COMPRESS_DEPENDS_u-boot = "u-boot-mkimage-native"
14COMPRESS_CMD_u-boot = "oe_mkimage ${IMAGE_NAME}.rootfs.${type} none"
15
16COMPRESS_DEPENDS_gz.u-boot = "u-boot-mkimage-native"
17COMPRESS_CMD_gz.u-boot = "${COMPRESS_CMD_gz}; oe_mkimage ${IMAGE_NAME}.rootfs.${type}.gz gzip clean"
18
19COMPRESS_DEPENDS_bz2.u-boot = "u-boot-mkimage-native"
20COMPRESS_CMD_bz2.u-boot = "${COMPRESS_CMD_bz2}; oe_mkimage ${IMAGE_NAME}.rootfs.${type}.bz2 bzip2 clean"
21
22COMPRESS_DEPENDS_lzma.u-boot = "u-boot-mkimage-native"
23COMPRESS_CMD_lzma.u-boot = "${COMPRESS_CMD_lzma}; oe_mkimage ${IMAGE_NAME}.rootfs.${type}.lzma lzma clean"
24
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050025IMAGE_TYPES += "ext2.u-boot ext2.gz.u-boot ext2.bz2.u-boot ext2.lzma.u-boot ext3.gz.u-boot ext4.gz.u-boot cpio.gz.u-boot"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026