blob: 38bdbd382217271ed5b5fba11bb0110872858524 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Class for packagegroup (package group) recipes
2
3# By default, only the packagegroup package itself is in PACKAGES.
4# -dbg and -dev flavours are handled by the anonfunc below.
5# This means that packagegroup recipes used to build multiple packagegroup
6# packages have to modify PACKAGES after inheriting packagegroup.bbclass.
7PACKAGES = "${PN}"
8
9# By default, packagegroup packages do not depend on a certain architecture.
10# Only if dependencies are modified by MACHINE_FEATURES, packages
11# need to be set to MACHINE_ARCH after inheriting packagegroup.bbclass
12PACKAGE_ARCH ?= "all"
13
14# Fully expanded - so it applies the overrides as well
15PACKAGE_ARCH_EXPANDED := "${PACKAGE_ARCH}"
16
17inherit ${@oe.utils.ifelse(d.getVar('PACKAGE_ARCH_EXPANDED', True) == 'all', 'allarch', '')}
18
19# This automatically adds -dbg and -dev flavours of all PACKAGES
20# to the list. Their dependencies (RRECOMMENDS) are handled as usual
21# by package_depchains in a following step.
22# Also mark all packages as ALLOW_EMPTY
23python () {
24 packages = d.getVar('PACKAGES', True).split()
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025 if d.getVar('PACKAGEGROUP_DISABLE_COMPLEMENTARY', True) != '1':
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050026 types = ['', '-dbg', '-dev']
27 if bb.utils.contains('DISTRO_FEATURES', 'ptest', True, False, d):
28 types.append('-ptest')
29 packages = [pkg + suffix for pkg in packages
30 for suffix in types]
31 d.setVar('PACKAGES', ' '.join(packages))
32 for pkg in packages:
33 d.setVar('ALLOW_EMPTY_%s' % pkg, '1')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034}
35
36# We don't want to look at shared library dependencies for the
37# dbg packages
38DEPCHAIN_DBGDEFAULTDEPS = "1"
39
40# We only need the packaging tasks - disable the rest
41do_fetch[noexec] = "1"
42do_unpack[noexec] = "1"
43do_patch[noexec] = "1"
44do_configure[noexec] = "1"
45do_compile[noexec] = "1"
46do_install[noexec] = "1"
47do_populate_sysroot[noexec] = "1"
48
49python () {
50 initman = d.getVar("VIRTUAL-RUNTIME_init_manager", True)
51 if initman and initman in ['sysvinit', 'systemd'] and not bb.utils.contains('DISTRO_FEATURES', initman, True, False, d):
52 bb.fatal("Please ensure that your setting of VIRTUAL-RUNTIME_init_manager (%s) matches the entries enabled in DISTRO_FEATURES" % initman)
53}
54