blob: 3fd0cd58f94e5a1e2b17b7fca0d007e1949f0aeb [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001# This class removes libtool .la files after do_install
2
3REMOVE_LIBTOOL_LA ?= "1"
4
5remove_libtool_la() {
6 if [ "${REMOVE_LIBTOOL_LA}" != "0" ]; then
7 find "${D}" -ignore_readdir_race -name "*.la" -delete
8 fi
9}
10
11do_install[postfuncs] += "remove_libtool_la"