blob: e0a22b773c80db67e928b2cc71032c350abdc436 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Copyright (C) 2013 Intel Corporation
2#
3# Released under the MIT license (see COPYING.MIT)
4
5
6# Run tests automatically on an image after the image is constructed
7# (as opposed to testimage.bbclass alone where tests must be called
8# manually using bitbake -c testimage <image>).
9#
10# NOTE: to use this class, simply set TEST_IMAGE = "1" - no need to
11# inherit it since that will be done in image.bbclass when this variable
12# has been set.
13#
14# See testimage.bbclass for the test implementation.
15
16inherit testimage
17
18python do_testimage_auto() {
19 testimage_main(d)
20}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050021addtask testimage_auto before do_build after do_image_complete
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022do_testimage_auto[depends] += "${TESTIMAGEDEPENDS}"
23do_testimage_auto[lockfiles] += "${TESTIMAGELOCK}"