blob: dfda5c1d307d5a679b275742c8ead6c644885d84 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
4SECTION = "bootloader"
5DEPENDS = "mtd-utils"
6
7# This revision corresponds to the tag "v2016.03"
8# We use the revision in order to avoid having to fetch it from the
9# repo during parse
10SRCREV = "df61a74e6845ec9bdcdd48d2aff5e9c2c6debeaa"
11
12PV = "v2016.03+git${SRCPV}"
13
14SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
15
16S = "${WORKDIR}/git"
17
18INSANE_SKIP_${PN} = "already-stripped"
19EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
20EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
21
22inherit uboot-config
23
24do_compile () {
25 oe_runmake ${UBOOT_MACHINE}
26 oe_runmake env
27}
28
29do_install () {
30 install -d ${D}${base_sbindir}
31 install -d ${D}${sysconfdir}
32 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
33 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
34 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
35}
36
37do_install_class-cross () {
38 install -d ${D}${bindir_cross}
39 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
40 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
41}
42
43SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
44uboot_fw_utils_cross() {
45 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
46}
47
48PACKAGE_ARCH = "${MACHINE_ARCH}"
49BBCLASSEXTEND = "cross"