blob: d5921a0443da67f71b83092964746ba0e3e4a1bd [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "U-Boot bootloader image creation tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
4SECTION = "bootloader"
5
6DEPENDS = "openssl"
7
8# This revision corresponds to the tag "v2016.03"
9# We use the revision in order to avoid having to fetch it from the
10# repo during parse
11SRCREV = "df61a74e6845ec9bdcdd48d2aff5e9c2c6debeaa"
12
13PV = "v2016.03+git${SRCPV}"
14
15SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
20
21do_compile () {
22 oe_runmake sandbox_defconfig
23 oe_runmake cross_tools NO_SDL=1
24}
25
26do_install () {
27 install -d ${D}${bindir}
28 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
29 ln -sf uboot-mkimage ${D}${bindir}/mkimage
30}
31
32BBCLASSEXTEND = "native nativesdk"