blob: 6865e7ad63039e5740376aa49f733b21cca1e3f7 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "nl80211 based CLI configuration utility for wireless devices"
2DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \
3wireless devices. It supports almost all new drivers that have been added \
4to the kernel recently. "
5HOMEPAGE = "http://wireless.kernel.org/en/users/Documentation/iw"
6SECTION = "base"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
9
10DEPENDS = "libnl"
11
12SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.gz \
13 file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \
14 file://separate-objdir.patch \
15"
16
17SRC_URI[md5sum] = "5ca622a270687d6862c9024fab266871"
18SRC_URI[sha256sum] = "2a853d95ffbd2b06c058b40ef4e6fa76a52c2709b05fb1976761fe13e9d9e39f"
19
20inherit pkgconfig
21
22EXTRA_OEMAKE = "\
23 -f '${S}/Makefile' \
24 \
25 'PREFIX=${prefix}' \
26 'SBINDIR=${sbindir}' \
27 'MANDIR=${mandir}' \
28"
29B = "${WORKDIR}/build"
30
31do_install() {
32 oe_runmake 'DESTDIR=${D}' install
33}