blob: a6268f3d474af60a363c93daef69d24f46e8e006 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "userspace utilities for kernel nfs"
2DESCRIPTION = "The nfs-utils package provides a daemon for the kernel \
3NFS server and related tools."
4HOMEPAGE = "http://nfs.sourceforge.net/"
5SECTION = "console/network"
6
7LICENSE = "MIT & GPLv2+ & BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=95f3a93a5c3c7888de623b46ea085a84"
9
10# util-linux for libblkid
11DEPENDS = "libcap libnfsidmap libevent util-linux sqlite3 libtirpc"
12RDEPENDS_${PN}-client = "rpcbind bash"
13RDEPENDS_${PN} = "${PN}-client bash"
14RRECOMMENDS_${PN} = "kernel-module-nfsd"
15
16inherit useradd
17
18USERADD_PACKAGES = "${PN}-client"
19USERADD_PARAM_${PN}-client = "--system --home-dir /var/lib/nfs \
20 --shell /bin/false --user-group rpcuser"
21
22SRC_URI = "${KERNELORG_MIRROR}/linux/utils/nfs-utils/${PV}/nfs-utils-${PV}.tar.xz \
23 file://0001-configure-Allow-to-explicitly-disable-nfsidmap.patch \
24 file://nfs-utils-1.2.3-sm-notify-res_init.patch \
25 file://nfsserver \
26 file://nfscommon \
27 file://nfs-utils.conf \
28 file://nfs-server.service \
29 file://nfs-mountd.service \
30 file://nfs-statd.service \
31 file://proc-fs-nfsd.mount \
32 file://nfs-utils-Do-not-pass-CFLAGS-to-gcc-while-building.patch \
33 file://nfs-utils-debianize-start-statd.patch \
34 file://0001-nfs-utils-statd-fix-a-segfault-caused-by-improper-us.patch \
35 file://bugfix-adjust-statd-service-name.patch \
36"
37
38SRC_URI[md5sum] = "cd6b568c2e9301cc3bfac09d87fbbc0b"
39SRC_URI[sha256sum] = "700d689c5622c87953c34102e5befafc4d3c811e676852238f0dd79c9c0c084d"
40
41# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
42# pull in the remainder of the dependencies.
43
44INITSCRIPT_PACKAGES = "${PN} ${PN}-client"
45INITSCRIPT_NAME = "nfsserver"
46INITSCRIPT_PARAMS = "defaults"
47INITSCRIPT_NAME_${PN}-client = "nfscommon"
48INITSCRIPT_PARAMS_${PN}-client = "defaults 19 21"
49
50inherit autotools-brokensep update-rc.d systemd pkgconfig
51
52SYSTEMD_SERVICE_${PN} = "nfs-server.service nfs-mountd.service"
53SYSTEMD_SERVICE_${PN}-client = "nfs-statd.service"
54SYSTEMD_AUTO_ENABLE = "disable"
55
56# --enable-uuid is need for cross-compiling
57EXTRA_OECONF = "--with-statduser=rpcuser \
58 --enable-mountconfig \
59 --enable-libmount-mount \
60 --disable-nfsv41 \
61 --enable-uuid \
62 --disable-gss \
63 --disable-nfsdcltrack \
64 --with-statdpath=/var/lib/nfs/statd \
65 "
66
67PACKAGECONFIG ??= "tcp-wrappers"
68PACKAGECONFIG_remove_libc-musl = "tcp-wrappers"
69PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers,tcp-wrappers"
70PACKAGECONFIG[nfsidmap] = "--enable-nfsidmap,--disable-nfsidmap,keyutils"
71
72INHIBIT_AUTO_STAGE = "1"
73
74PACKAGES =+ "${PN}-client ${PN}-stats"
75
76CONFFILES_${PN}-client += "${localstatedir}/lib/nfs/etab \
77 ${localstatedir}/lib/nfs/rmtab \
78 ${localstatedir}/lib/nfs/xtab \
79 ${localstatedir}/lib/nfs/statd/state \
80 ${sysconfdir}/nfsmount.conf"
81
82FILES_${PN}-client = "${base_sbindir}/*mount.nfs* ${sbindir}/*statd \
83 ${sbindir}/rpc.idmapd ${sbindir}/sm-notify \
84 ${sbindir}/showmount ${sbindir}/nfsstat \
85 ${localstatedir}/lib/nfs \
86 ${sysconfdir}/nfs-utils.conf \
87 ${sysconfdir}/nfsmount.conf \
88 ${sysconfdir}/init.d/nfscommon \
89 ${systemd_unitdir}/system/nfs-statd.service"
90FILES_${PN}-stats = "${sbindir}/mountstats ${sbindir}/nfsiostat"
91RDEPENDS_${PN}-stats = "python"
92
93FILES_${PN} += "${systemd_unitdir}"
94
95do_configure_prepend() {
96 sed -i -e 's,sbindir = /sbin,sbindir = ${base_sbindir},g' \
97 ${S}/utils/mount/Makefile.am
98
99 sed -i -e 's,sbindir = /sbin,sbindir = ${base_sbindir},g' \
100 ${S}/utils/osd_login/Makefile.am
101}
102
103# Make clean needed because the package comes with
104# precompiled 64-bit objects that break the build
105do_compile_prepend() {
106 make clean
107}
108
109do_install_append () {
110 install -d ${D}${sysconfdir}/init.d
111 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
112 install -m 0755 ${WORKDIR}/nfscommon ${D}${sysconfdir}/init.d/nfscommon
113
114 install -m 0755 ${WORKDIR}/nfs-utils.conf ${D}${sysconfdir}
115 install -m 0755 ${S}/utils/mount/nfsmount.conf ${D}${sysconfdir}
116
117 install -d ${D}${systemd_unitdir}/system
118 install -m 0644 ${WORKDIR}/nfs-server.service ${D}${systemd_unitdir}/system/
119 install -m 0644 ${WORKDIR}/nfs-mountd.service ${D}${systemd_unitdir}/system/
120 install -m 0644 ${WORKDIR}/nfs-statd.service ${D}${systemd_unitdir}/system/
121 sed -i -e 's,@SBINDIR@,${sbindir},g' \
122 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
123 ${D}${systemd_unitdir}/system/*.service
124 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
125 install -d ${D}${sysconfdir}/modules-load.d
126 echo "nfsd" > ${D}${sysconfdir}/modules-load.d/nfsd.conf
127 install -m 0644 ${WORKDIR}/proc-fs-nfsd.mount ${D}${systemd_unitdir}/system/
128 install -d ${D}${systemd_unitdir}/system/sysinit.target.wants/
129 ln -sf ../proc-fs-nfsd.mount ${D}${systemd_unitdir}/system/sysinit.target.wants/proc-fs-nfsd.mount
130 fi
131
132 # kernel code as of 3.8 hard-codes this path as a default
133 install -d ${D}/var/lib/nfs/v4recovery
134
135 # chown the directories and files
136 chown -R rpcuser:rpcuser ${D}${localstatedir}/lib/nfs/statd
137 chmod 0644 ${D}${localstatedir}/lib/nfs/statd/state
138
139 # the following are built by CC_FOR_BUILD
140 rm -f ${D}${sbindir}/rpcdebug
141 rm -f ${D}${sbindir}/rpcgen
142 rm -f ${D}${sbindir}/locktest
143}