blob: 290f129fc09fa15b7fc017133cb54d6939dad086 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001require openssl.inc
2
3# For target side versions of openssl enable support for OCF Linux driver
4# if they are available.
5DEPENDS += "cryptodev-linux"
6
7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=27ffa5d74bb5a337056c14b2ef93fbf6"
10
11export DIRS = "crypto ssl apps engines"
12export OE_LDFLAGS="${LDFLAGS}"
13
14SRC_URI += "file://find.pl;subdir=${BP}/util/ \
15 file://run-ptest \
16 file://configure-targets.patch \
17 file://shared-libs.patch \
18 file://oe-ldflags.patch \
19 file://engines-install-in-libdir-ssl.patch \
20 file://debian1.0.2/block_diginotar.patch \
21 file://debian1.0.2/block_digicert_malaysia.patch \
22 file://debian/ca.patch \
23 file://debian/c_rehash-compat.patch \
24 file://debian/debian-targets.patch \
25 file://debian/man-dir.patch \
26 file://debian/man-section.patch \
27 file://debian/no-rpath.patch \
28 file://debian/no-symbolic.patch \
29 file://debian/pic.patch \
30 file://debian1.0.2/version-script.patch \
31 file://openssl_fix_for_x32.patch \
32 file://fix-cipher-des-ede3-cfb1.patch \
33 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
34 file://openssl-fix-des.pod-error.patch \
35 file://Makefiles-ptest.patch \
36 file://ptest-deps.patch \
37 file://crypto_use_bigint_in_x86-64_perl.patch \
38 file://openssl-1.0.2a-x32-asm.patch \
39 file://ptest_makefile_deps.patch \
40 file://configure-musl-target.patch \
41 file://parallel.patch \
42 "
43
44SRC_URI[md5sum] = "f3c710c045cdee5fd114feb69feba7aa"
45SRC_URI[sha256sum] = "b784b1b3907ce39abf4098702dade6365522a253ad1552e267a9a0e89594aa33"
46
47PACKAGES =+ "${PN}-engines"
48FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
49
50# The crypto_use_bigint patch means that perl's bignum module needs to be
51# installed, but some distributions (for example Fedora 23) don't ship it by
52# default. As the resulting error is very misleading check for bignum before
53# building.
54do_configure_prepend() {
55 if ! perl -Mbigint -e true; then
56 bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake."
57 fi
58}