blob: c301720768fa0edaf88e18e9424bfa67e06ac256 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "keith bostic's POSIX file tree stream operations library"
5HOMEPAGE = "https://sites.google.com/a/bostic.com/keithbostic"
6LICENSE = "BSD-4-Clause"
7LIC_FILES_CHKSUM = "file://fts.h;beginline=1;endline=36;md5=2532eddb3d1a21905723a4011ec4e085"
8SECTION = "libs"
9
10SRC_URI = "https://sites.google.com/a/bostic.com/keithbostic/files/fts.tar.gz \
11 file://fts-header-correctness.patch \
12 file://fts-uclibc.patch \
13 file://remove_cdefs.patch \
14 file://stdint.patch \
15 file://gcc5.patch \
16"
17
18SRC_URI[md5sum] = "120c14715485ec6ced14f494d059d20a"
19SRC_URI[sha256sum] = "3df9b9b5a45aeaf16f33bb84e692a10dc662e22ec8a51748f98767d67fb6f342"
20
21S = "${WORKDIR}/${BPN}"
22
23do_configure[noexec] = "1"
24
25HASHSTYLE_mips = "sysv"
26HASHSTYLE_mipsel = "sysv"
27HASHSTYLE_mips64 = "sysv"
28HASHSTYLE_mips64el = "sysv"
29HASHSTYLE = "gnu"
30
31VER = "0"
32do_compile () {
33 ${CC} -I${S} -fPIC -shared -Wl,--hash-style=${HASHSTYLE} -o libfts.so.${VER} -Wl,-soname,libfts.so.${VER} ${S}/fts.c
34}
35
36do_install() {
37 install -Dm755 ${B}/libfts.so.${VER} ${D}${libdir}/libfts.so.${VER}
38 ln -sf libfts.so.${VER} ${D}${libdir}/libfts.so
39 install -Dm644 ${S}/fts.h ${D}${includedir}/fts.h
40}
41#
42# We will skip parsing for non-musl systems
43#
44COMPATIBLE_HOST = ".*-musl.*"
45