blob: 9c9873fbd0252b7b8886c056c81ea44864506f16 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "XML C Parser Library and Toolkit"
2DESCRIPTION = "The XML Parser Library allows for manipulation of XML files. Libxml2 exports Push and Pull type parser interfaces for both XML and HTML. It can do DTD validation at parse time, on a parsed document instance or with an arbitrary DTD. Libxml2 includes complete XPath, XPointer and Xinclude implementations. It also has a SAX like interface, which is designed to be compatible with Expat."
3HOMEPAGE = "http://www.xmlsoft.org/"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml2"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
8 file://hash.c;beginline=6;endline=15;md5=96f7296605eae807670fb08947829969 \
9 file://list.c;beginline=4;endline=13;md5=cdbfa3dee51c099edb04e39f762ee907 \
10 file://trio.c;beginline=5;endline=14;md5=6c025753c86d958722ec76e94cae932e"
11
12DEPENDS = "zlib"
13
14SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz;name=libtar \
15 http://www.w3.org/XML/Test/xmlts20080827.tar.gz;name=testtar \
16 file://libxml-64bit.patch \
17 file://ansidecl.patch \
18 file://runtest.patch \
19 file://run-ptest \
20 file://python-sitepackages-dir.patch \
21 file://libxml-m4-use-pkgconfig.patch \
22 file://configure.ac-fix-cross-compiling-warning.patch \
23 "
24
25SRC_URI[libtar.md5sum] = "daece17e045f1c107610e137ab50c179"
26SRC_URI[libtar.sha256sum] = "4de9e31f46b44d34871c22f54bfc54398ef124d6f7cafb1f4a5958fbcd3ba12d"
27SRC_URI[testtar.md5sum] = "ae3d1ebe000a3972afa104ca7f0e1b4a"
28SRC_URI[testtar.sha256sum] = "96151685cec997e1f9f3387e3626d61e6284d4d6e66e0e440c209286c03e9cc7"
29
30BINCONFIG = "${bindir}/xml2-config"
31
32inherit autotools pkgconfig binconfig-disabled pythonnative ptest
33
34RDEPENDS_${PN}-ptest += "python-core"
35
36RDEPENDS_${PN}-python += "python-core"
37
38RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-gconv-ebcdic-us glibc-gconv-ibm1141"
39
40export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
41
42PACKAGECONFIG ??= "python"
43PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python"
44
45# WARNING: zlib is require for RPM use
46EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
47EXTRA_OECONF_class-native = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
48EXTRA_OECONF_class-nativesdk = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
49EXTRA_OECONF_linuxstdbase = "--with-debug --with-legacy --with-docbook --with-c14n --without-lzma --with-zlib"
50
51# required for python binding
52export HOST_SYS
53export BUILD_SYS
54export STAGING_LIBDIR
55export STAGING_INCDIR
56
57python populate_packages_prepend () {
58 # autonamer would call this libxml2-2, but we don't want that
59 if d.getVar('DEBIAN_NAMES', True):
60 d.setVar('PKG_libxml2', '${MLPREFIX}libxml2')
61}
62
63PACKAGES += "${PN}-utils ${PN}-python"
64
65FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
66FILES_${PN}-dev += "${libdir}/xml2Conf.sh ${libdir}/cmake/*"
67FILES_${PN}-utils += "${bindir}/*"
68FILES_${PN}-python += "${PYTHON_SITEPACKAGES_DIR}"
69
70do_install_ptest () {
71 cp -r ${WORKDIR}/xmlconf ${D}${PTEST_PATH}
72}
73
74BBCLASSEXTEND = "native nativesdk"